|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #50497 php 5.3.2 requires ANSI C99 compliant compiler
Submitted: 2009-12-16 20:43 UTC Modified: 2009-12-16 21:12 UTC
From: Assigned:
Status: Not a bug Package: *Compile Issues
PHP Version: 5.3SVN-2009-12-16 (SVN) OS: linux, solaris
Private report: No CVE-ID:
 [2009-12-16 20:43 UTC]
php 5.3.x requires ANSIC 99 compliant complier options. php configure 
options can check for this and enable this option accordingly

Reproduce code:
if we try compile php 5.3.x on gcc 2.96 or other compilers which do not enable ansi c 99 standard and its extensions by default, php build will fail. this is because php now includes such extensions internally.

for example, within , we could add the following macro

to ensure that the compiler can support ansi c 99 standard. 

(need to check if this macro is available in autoconf 2.13 - the officially supported macro for php 5.3)

Expected result:
build passes successfully or fails at the configure state

Actual result:
configure passes successfully and fails while compiling some programs 
causing confusion to the customers


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2009-12-16 21:10 UTC]
Why this bug report?

no need to duplucate > bogus.
 [2009-12-16 21:12 UTC]
PHP Copyright © 2001-2015 The PHP Group
All rights reserved.
Last updated: Sat Nov 28 22:01:36 2015 UTC