php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #50492 [PT_BR] As saídas de echo e print são enviadas para
Submitted: 2009-12-16 13:31 UTC Modified: 2010-10-23 14:16 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: rubens21 at gmail dot com Assigned: kalle (profile)
Status: Closed Package: Translation problem
PHP Version: Irrelevant OS: Irrelevant
Private report: No CVE-ID: None
 [2009-12-16 13:31 UTC] rubens21 at gmail dot com
Description:
------------
O texto não foi atualizado desde a versão 4.1.0.
A parte que fala 'não é possível enviar saída para o brownser usando echo() ou print()' está desatualizado. Os 'echo's e 'print's chamados dentro das funções registradas pelo 'register_shutdown_function' são enviados para o navegador desde a versão 4.1.0.




Reproduce code:
---------------
---
From manual page: function.register-shutdown-function#Descrição
---


register_shutdown_function('saida');
echo "Aqui é no script";
exit("\npedi para encerrar o script");
function saida()
{
   echo "\nIsso é visto no navegador";
   print "\nIsso também";
}


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-12-18 06:11 UTC] kalle@php.net
Is this a documentation bug or is it a translation bug? And please use english language for future replies/reports, Thanks.
 [2009-12-18 10:27 UTC] rubens21 at gmail dot com
I'm sory. I forgot because the documentation are in portuguese.

It is a documentation problem. It is out of date.
In english documentation the text is correct, but in portuguese (http://www.php.net/manual/pt_BR/function.register-shutdown-function.php) the translated of 'so it was not possible to send output to the browser using echo() or print()' is incorrect!

The correct is:
"As funções "shutdown" registradas 'ERAM' chamadas após a requisição ter sido completamente feita (incluindo envio e saída de buffer), então isso não 'ERA' possível enviar saída para o brownser usando echo() ou print(), ou recuperar o conteúdo de algum buffer de saída usando ob_get_contents()."

This text explain a change of version 4.1.
 [2009-12-18 13:20 UTC] kalle@php.net
Thanks for explaining, I've re-classified this so the translation team can easier find it.
 [2010-10-23 12:59 UTC] kalle@php.net
-Type: Bug +Type: Documentation Problem
 [2010-10-23 14:15 UTC] kalle@php.net
I had a deeper look at this and the pt_BR translation and that file is way outdated and currently does not contain that note anymore. It will be fixed once a translator updates the file.

Thanks for your report
 [2010-10-23 14:16 UTC] kalle@php.net
-Status: Verified +Status: Closed -Assigned To: +Assigned To: kalle
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Jun 20 18:01:30 2024 UTC