php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #50443 RHES5 - Bug #41337 WSDL parsing doesn't ignore non soap bindings
Submitted: 2009-12-10 20:44 UTC Modified: 2009-12-15 07:04 UTC
From: phpbug at em dot stonedrop dot com Assigned:
Status: Not a bug Package: SOAP related
PHP Version: 5.2.11 OS: RedHat Enterprise 5.4
Private report: No CVE-ID: None
 [2009-12-10 20:44 UTC] phpbug at em dot stonedrop dot com
Description:
------------
This is a follow up to the issue described below, and in reference to 
PHP 5.1.6 (RHEL 5.1.6-23.2.el5_3).

http://bugs.php.net/bug.php?id=41337

We are experiencing what appears to be this issue, as a growing number of vendors that implement SOAP communication are introduced POX binding to WCF services.

As you are probably aware, RHES5 is shipped with PHP 5.1 and there is no simple path for upgrade without removing the supported version and installing a community or source-based installation.  

According to the above report, this was fixed in CVS for 5.2.2, but was this ever back-ported to the 5.1.x version of php-soap?  Otherwise, is there a workaround?

Many thanks.


Reproduce code:
---------------
Examples on http://bugs.php.net/bug.php?id=41337 apply

Example:

<wsdl:service name="SubscriberService">
  <wsdl:port name="SecureSubscriberServiceBasicBinding" binding="tns:SecureSubscriberServiceBasicBinding">
    <soap:address location="https://services.contentdirect.tv/v3.0/SubscriberService.svc"/>
  </wsdl:port>
  <wsdl:port name="SecureSubscriberServiceBasicBindingWebHttp" binding="tns:SecureSubscriberServiceBasicBindingWebHttp"/>
</wsdl:service>


Expected result:
----------------
WSDL is parsed, and calls succeed.

Actual result:
--------------
PHP Fatal error:  SOAP-ERROR: Parsing WSDL: No address associated with <port> 

Exception thrown

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-12-15 07:04 UTC] aharvey@php.net
Since I'm fairly sure Johannes meant to post this here rather than bug #41337, I'll quote what he said there:

"Please talk to RedHat if you need fixes. We don't support PHP 5.1
anymore. 5.2 is out for more than three years and we're already on 5.3
..."

FWIW, the SVN revisions that fixed bug #41337 on the 5.2 branch were 235340 and 236042, should you wish to follow it up with Red Hat -- that would presumably be where they would need to start with any backport.

Glancing over the diff, I can't see any obvious way this could be worked around from userspace code short of preprocessing the WSDL, which I wouldn't particularly recommend.

(Closing the bug, since it's an issue for Red Hat to deal with on their branch of 5.1.6, rather than for the PHP development team as such.)
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Dec 07 02:03:34 2021 UTC