php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #50433 mysql extensions don't work
Submitted: 2009-12-09 21:31 UTC Modified: 2009-12-24 11:44 UTC
Votes:4
Avg. Score:5.0 ± 0.0
Reproduced:4 of 4 (100.0%)
Same Version:4 (100.0%)
Same OS:2 (50.0%)
From: darkdominiongr at gmail dot com Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 5.3.1 OS: win32 only - Windows 7 x64
Private report: No CVE-ID: None
 [2009-12-09 21:31 UTC] darkdominiongr at gmail dot com
Description:
------------
The mysql extensions for PHP 5.3.1 don't work. I never had a problem with PHP 5.3.0 but when i upgraded to 5.3.1. i couldn't use the mysql functions. 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-12-09 21:54 UTC] pajoye@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a short but complete example script to be able to reproduce
this bug ourselves. 

A proper reproducing script starts with <?php and ends with ?>,
is max. 10-20 lines long and does not require any external 
resources such as databases, etc. If the script requires a 
database to demonstrate the issue, please make sure it creates 
all necessary tables, stored procedures etc.

Please avoid embedding huge scripts into the report.


 [2009-12-09 23:13 UTC] darkdominiongr at gmail dot com
<?php

	$host = "******";
	$username = "******";
	$password = "******";

	mysql_connect("$host","$username","$password") or die("couldn't establish connection: " . mysql_error());
	echo "Connected to MySQL";
?>

When i try this code in php 5.3.0 i get the "connected to mysql" message correctly. But when i try it on 5.3.1 i get the following message.

couldn't establish connection: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
 [2009-12-10 07:03 UTC] jani@php.net
Some windows issue, on *nix everything works just fine.
 [2009-12-12 19:01 UTC] darkdominiongr at gmail dot com
Can someone verify this on a Windows server?
 [2009-12-14 21:50 UTC] SKJoy2001 at InBox dot Com
System: Intel Core i7 with 2x3 DDR III
OS: Microsoft Windows 7 Ultimate
Web server: IIS 7.5
PHP: 5.3.1 (CGI)

PHPMyAdmin fails to load but the native 'mysql_connect' & 'mysql_select_db' is working fine on test scripts.
 [2009-12-24 00:25 UTC] ewal at pointpro dot nl
I can confirm this problem; first ran into it on a Windows 2008 R2 server x64 and then confirmed on a Windows 7 x64 machine. It does work in 5.3.0.
 [2009-12-24 00:41 UTC] rasmus@php.net
Is this the ipv6 ::1 localhost problem again?  
Does it work if you connect to "127.0.0.1" instead of "localhost" ?
 [2009-12-24 00:52 UTC] darkdominiongr at gmail dot com
Well it is the ip v6 problem. So this is not a bug.
 [2009-12-24 11:44 UTC] pajoye@php.net
IPv6 config issue > not a bug > bogus.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Jul 02 18:03:35 2022 UTC