php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #50406 Curl causing high cpu usage
Submitted: 2009-12-08 04:07 UTC Modified: 2009-12-08 04:55 UTC
From: matthew at crasxit dot net Assigned:
Status: Not a bug Package: cURL related
PHP Version: 5.3.1 OS: Windows 2008
Private report: No CVE-ID:
 [2009-12-08 04:07 UTC] matthew at crasxit dot net
Description:
------------
I'm having an issue with curl on windows with php. If i have curl enabled in php and i run php through command line i get an instant cpu spike... php.exe cpu jumps to about 20% then back down. when i disable curl it only jumps to about 2%
it does this on non curl scripts. even if i run a blank php file or php -i it jumps to 20... however httpd.exe using apache2_2.dll seems to be fine (~2%)

extensions loaded:
curl (problem with curl, fine without)
gd2
mbstring
mysql
mysqli
openssl


Reproduce code:
---------------
any code


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-12-08 04:55 UTC] scottmac@php.net
There is a lot of initialisation code within the curl module that needs to be run when PHP is started. It's a one time cost when using fastcgi / apache but with CLI you get it on every script executed.

 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 16 18:01:53 2014 UTC