php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #50138 "extends" translation is "extend" in the interface documentation
Submitted: 2009-11-10 13:48 UTC Modified: 2010-08-06 07:32 UTC
From: y14jem-php at yahoo dot fr Assigned: pierrick (profile)
Status: Closed Package: Translation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2009-11-10 13:48 UTC] y14jem-php at yahoo dot fr
Description:
------------
Url : http://www.php.net/manual/en/language.oop5.interfaces.php
About the outlined note (in english) :
"Note: Interfaces can be extended like classes using the extends operator."

The keyword "extends" is translated as "extend" and the hyperlink isn't present in the following languages :
french, bulgarian, german, bresilian portuguese


Reproduce code:
---------------
French :
http://www.php.net/manual/fr/language.oop5.interfaces.php
Note: Les interfaces peuvent ?tre ?tendues comme des classes en utilisant l'op?rateur extend.

Bulgarian
http://www.php.net/manual/bg/language.oop5.interfaces.php
Забележка: Интерфейсите могат да бъдат разширявани, също какт класовете, посредством оператора extend  

German
http://www.php.net/manual/de/language.oop5.interfaces.php
Hinweis: Ein Interface kann ebenso wie eine Klasse mit Hilfe des Schl?sselwortes extend erweitert werden. 

Bresilian portuguese
http://www.php.net/manual/pt_BR/language.oop5.interfaces.php
Nota: Interfaces podem ser estendidas como classes, usando o operador extend. 



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-11-10 14:42 UTC] rquadling@php.net
The change to the English documentation (extend => extends) was done not 
too long ago.

The translations haven't caught up.

See http://bugs.php.net/bug.php?id=50002
 [2010-08-06 07:32 UTC] pierrick@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: pierrick
 [2010-08-06 07:32 UTC] pierrick@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Feb 21 16:01:27 2020 UTC