php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #50017 Nomenclature ltrim/rtrim semantically incorrect, ignores RTL writing systems!
Submitted: 2009-10-27 12:05 UTC Modified: 2009-11-15 20:03 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: stefan at digitalekunst dot ac dot at Assigned: thiago (profile)
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2009-10-27 12:05 UTC] stefan at digitalekunst dot ac dot at
Description:
------------
I have posted a comment at:
http://www.php.net/manual/en/function.ltrim.php#68677

It was removed! Why?
My content did not contradict the rules.
I guess it was removed because I critisiced the naming convention of 
ltrim/rtrim, and agreed with "Usamah M dot Ali".

1) I did not save a copy of the comment on my computer. Is there a 
versioning system of the documentation comments, which can restore my 
comment? I would like to have it for myself please, and as the 
original source for discussing the issue!
2) I would like a serious explanation, why it was removed.
3) I would like to stimulate a discussion, about what I criticized. I 
think that cultural ignorance/unawareness is simply not a good mindset 
for a globalized co-operation project such as PHP.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-10-27 12:23 UTC] thiago@php.net
Stefan, I removed your comment for the following reasons:

1 - Usamah's comment is enough for explaining the function differences on those languages.
2 - It just stands for saying your opinion, and doc notes are not the right place for this.
3 - You're suggesting a change/fix/feature, it should be done by adding a bug on this system.


Your original comment is below:
I agree with Usamah M dot Ali (usamah1228 at gmail dot com)!

I think that the nomenclature of ltrim and rtrim is very poor, as it has a bias towards left-to-right writing systems!

I suggest to rather call them btrim (trim at beginning of the character stream) and etrim (trim at end of the character stream), as this would be universally true without any bias.

Honestly this issue doesn't amaze me, because it reflects the sad reality that quite a number of people, studying technical subjects, often don't receive any humanistic/general education in their curricula at all!
 [2009-10-27 15:27 UTC] philip@php.net
Agreed, this comment doesn't add anything useful to the PHP Manual. We 
document ltrim() as ltrim() because it's named ltrim(). Same logic 
applies to rtrim().

However, information based on the user note from Usamah deserves 
integration into the manual for these two pages.

As for the topic itself, I highly doubt these commonly used functions 
will be renamed (or aliased) and instead assume proper documentation 
will be the solution. However, discussing on internals@lists.php.net 
is possible.

Note: all user note activity is archived here:

- http://news.php.net/php.notes

And your note being deleted:

- http://news.php.net/php.notes/162109

 [2009-10-27 18:42 UTC] stefan at digitalekunst dot ac dot at
@thiago & @philip

1) Thanks for:
(a) Showing me how to access deleted comments: Both mine and in 
general.
(b) The reasoning for the deletion.
This is good transparency (at least after my request).

2) For even better transparency, I have some ideas:
(a) Notify the submitting email-address about deletion. I only 
realised the deletion by revisiting and looking for reactions.
b) When deleting/rejecting comments possibly add a 
standardized/individual reasoning remark.
(c) Javascript on comment page: When someone requests an orphaned 
anchor on a PHP manual page, such as:
http://www.php.net/manual/en/function.ltrim.php#comment-id
Inform, that the comment was removed, and may offer a link to:
http://news.php.net/php.notes/comment-id

3) Concerning the issue:
(a) I understand that renaming such a heavily used function is out of 
the question. But nevertheless I propose consequences:
(b) Nomenclature/style guidelines which emphasize to be as 
cultural/ideology neutral and as universal as possible.
(c) Demonstrate your respect/sensitivity towards cultural openness by 
now retroactively establishing the aliases whose documentation shall 
have a slight section, which explains that the aliases were added 
because of the respect/openness approach, and links to the 
nomenclature/style guidelines.

4)  What are the further steps?
(a) Is the discussion continued here, or will the issue be transferred 
to internals@lists.php.net? Are you doing this, or shall I do it?
(b) Who will be the final decision maker?
 [2009-10-27 19:16 UTC] thiago@php.net
2) For even better transparency, I have some ideas:
(a/b) Notify the submitting email-address about deletion.
This already happens, but in your note you did not specify an email address, all you typed on your email was: "StefanNowak". We can't send an email to that. :)

2) (c) JS on docs...
I'm not sure why (probably for usability), but we don't use JS on php.net website. This could be more clarified by someone responsible.


3) Concerning the issue:
(c) Demonstrate your respect/sensitivity...
This could be done by adding some of Usamah's text into docs.


4)  What are the further steps?
(a) Is the discussion continued here...
This bug will be here so we can track the new text to be added. 

(b) Who will be the final decision maker?
Probably Phillip :)


I don't feel confident enough to add text to main EN tree, so if anyone else would take this, It'd be awesome.
 [2009-11-13 17:23 UTC] vrana@php.net
Purpose clearly states that ltrim trims characters from the beginning of a string which is consistent with Usamah M dot Ali comment.
 [2009-11-15 20:03 UTC] stefan at digitalekunst dot ac dot at
@vrana: Yes, the documentation purpose states "beginning of string..." 
and Usamah M dot Ali comment adds information concerning RTL writing 
system, which together is TECHNICALLY enough (for this single issue).

Nevertheless, as I wrote in my previous post, I am inquiring for:

3)(b) Nomenclature/style guidelines which emphasize to be as 
cultural/ideology neutral and as universal as possible (for future 
functionality).
(c) Demonstrate your respect/sensitivity towards cultural openness by 
now retroactively establishing the aliases whose documentation shall 
have a slight section, which explains that the aliases were added 
because of the respect/openness approach, and links to the 
nomenclature/style guidelines.

And yet nobody answered to:
4) What are the further steps?
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Oct 27 01:01:23 2020 UTC