php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #50002 Object Interfaces page refers to the "extend" rather than "extends" operator
Submitted: 2009-10-26 17:09 UTC Modified: 2009-10-27 13:05 UTC
Votes:2
Avg. Score:1.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: joshden at gmail dot com Assigned:
Status: Closed Package: Documentation problem
PHP Version: 5.3.0 OS:
Private report: No CVE-ID: None
 [2009-10-26 17:09 UTC] joshden at gmail dot com
Description:
------------
In the manual (Language Reference > Classes and Objects > Object Interfaces), the second note in the "implements" section reads as follows:

Note: Interfaces can be extended like classes using the extend operator. 


I believe the word "extend" should be "extends" and should read as follows:

Note: Interfaces can be extended like classes using the extends operator. 


This is the URL where I noticed this issue: http://www.php.net/manual/en/language.oop5.interfaces.php

Reproduce code:
---------------
---
From manual page: language.oop5.interfaces
---



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-10-27 12:56 UTC] svn@php.net
Automatic comment from SVN on behalf of rquadling
Revision: http://svn.php.net/viewvc/?view=revision&revision=289986
Log: Typo and link. Fix bug#50002
 [2009-10-27 13:05 UTC] rquadling@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Nov 28 18:03:14 2021 UTC