php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #49927 FR: version info on class synopsis pages
Submitted: 2009-10-19 20:46 UTC Modified: 2011-07-05 17:41 UTC
From: salathe@php.net Assigned: bjori
Status: Closed Package: Doc Build problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID:
 [2009-10-19 20:46 UTC] salathe@php.net
Description:
------------
Currently the class synopsis pages do not display the PHP version information for which they are available (e.g. "(PHP 5 >= 5.3.0)").  While this information is easily gleaned by a click through to the constructor's doc page (or another method), it would be nice to have this information visible on the synopsis page as a general, "this class is available in ...".

It is suggested to place this information immediately below the "Class synopsis" header, above the synopsis box.

Reproduce code:
---------------
Visit http://docs.php.net/class.splheap

Expected result:
----------------
Class synopsis
(PHP 5 >= 5.3.0)
SplHeap
abstract SplHeap implements...

Actual result:
--------------
Class synopsis
SplHeap
abstract SplHeap implements...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-03-12 16:22 UTC] moacir@php.net
-Type: Bug +Type: Feature/Change Request
 [2011-07-05 17:41 UTC] bjori@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: bjori
 [2011-07-05 17:41 UTC] bjori@php.net
This bug has been fixed in SVN. Since the websites are not directly
updated from the SVN server, the fix might need some time to spread
across the globe to all mirror sites, including PHP.net itself.

Thank you for the report, and for helping us make PHP.net better.

http://svn.php.net/viewvc?view=revision&revision=312958
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sat Apr 19 04:01:55 2014 UTC