php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #49882 imagelayereffect() not available with shared GD
Submitted: 2009-10-15 00:12 UTC Modified: 2016-07-16 01:44 UTC
Votes:12
Avg. Score:4.4 ± 0.8
Reproduced:11 of 11 (100.0%)
Same Version:4 (36.4%)
Same OS:4 (36.4%)
From: woody dot gilk at kohanaphp dot com Assigned: pajoye (profile)
Status: Closed Package: GD related
PHP Version: 5.3.0 OS: Mac OSX 10.5
Private report: No CVE-ID: None
 [2009-10-15 00:12 UTC] woody dot gilk at kohanaphp dot com
Description:
------------
Using shared GD with PHP 5.3.0 should work the same as using --with-
gd=php. However, this is not true.

Reproduce code:
---------------
~> php -r 'var_dump(PHP_VERSION);'
string(5) "5.3.0"
~> php -r 'var_dump(function_exists("imagerotate"));'
bool(true)
~> php -r 'var_dump(function_exists("imagelayereffect"));'
bool(false)

Expected result:
----------------
I expected the last command to show "bool(true)".

Actual result:
--------------
It shows "bool(false)".

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-10-15 00:19 UTC] pajoye@php.net
Quick note: It is not due to the bundled GD usages but the new feature in the configure script on php 5.3. This feature enables the bundled new functions even when the extension is built against the system library. imagelayereffect was forgotten.
 [2010-03-19 16:51 UTC] phpnet at bueckemeyer dot com
When will the function imagelayereffect work with the shared GD version?
 [2016-07-16 01:44 UTC] cmb@php.net
-Status: Assigned +Status: Closed
 [2016-07-16 01:44 UTC] cmb@php.net
This has already been implemented with
<https://github.com/php/php-src/commit/6aedadc>, and is supposed
to be available with all currently supported PHP versions.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Jul 18 11:01:25 2019 UTC