php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #49849 Minor issue with unwanted linebreaks
Submitted: 2009-10-12 18:05 UTC Modified: 2009-12-30 12:07 UTC
From: wiesemann@php.net Assigned:
Status: Closed Package: Doc Build problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2009-10-12 18:05 UTC] wiesemann@php.net
Description:
------------
PhD inserts unwanted linebreaks after e.g. the <parameter> tag. Example from the in_array() documentation:
+++
  <para>
   Searches <parameter>haystack</parameter> for <parameter>needle</parameter>.
  </para>
+++

This will be converted into this:
+++
  <p class="para rdfs-comment">

   Searches <i><tt class="parameter">haystack</tt></i>
 for <i><tt class="parameter">needle</tt></i>
.
  </p>
+++

This will be displayed like this in the browser:
+++
Searches haystack  for needle .
+++

There is a longer sentence on the same page that causes the period to be unnecessarily on its own line.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-12-26 10:42 UTC] bjori@php.net
PhD outputs all WS as-is. It doesn't normalize it or anything.
Thats a feature IMO, not a bug.
 [2009-12-28 18:31 UTC] wiesemann@php.net
My report clearly shows that "PhD outputs all WS as-is." can't be true. The linebreak between "</i>" and "." is only in the generated output, while the source code (in-array.xml) contains "</parameter>." (i.e. no WS). The same is true for the other occurence of the closing "</parameter>" tag in the same line.
 [2009-12-30 12:06 UTC] rquadling@php.net
PhD does append \n in several places. After some tags, this is rendered 
as additional whitespace. 


 [2009-12-30 12:06 UTC] svn@php.net
Automatic comment from SVN on behalf of rquadling
Revision: http://svn.php.net/viewvc/?view=revision&revision=292797
Log: Remove superfluous \n to output of PhD. This removes whitespace after some tags.
Fix #49849
 [2009-12-30 12:07 UTC] rquadling@php.net
This bug has been fixed in SVN. Since the websites are not directly
updated from the SVN server, the fix might need some time to spread
across the globe to all mirror sites, including PHP.net itself.

Thank you for the report, and for helping us make PHP.net better.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Nov 30 08:05:53 2022 UTC