php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #49837 Wrong SVN revision numbers in commit emails
Submitted: 2009-10-11 13:06 UTC Modified: 2013-06-05 17:16 UTC
From: wiesemann@php.net Assigned: danbrown (profile)
Status: Not a bug Package: Systems problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2009-10-11 13:06 UTC] wiesemann@php.net
Description:
------------
An example of the header of commit emails is this one:

> Revision: http://svn.php.net/viewvc?view=revision&revision=289301
> Modified: phpdoc/en/trunk/faq/using.xml
> ===================================================================
> --- phpdoc/en/trunk/faq/using.xml    2009-10-07 20:09:08 UTC (rev 289300)
> +++ phpdoc/en/trunk/faq/using.xml    2009-10-07 20:36:06 UTC (rev 289301) 

The old revision number is wrong, the correct number would be 289138:
http://svn.php.net/viewvc/phpdoc/en/trunk/faq/using.xml?view=log

This is also true for other commit emails. If the correct value can't be determined, I'd suggest to remove this information.

Another problem is that on multiple file commits actually a list of old revision numbers would be needed if the files had different revision numbers.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-10-11 19:32 UTC] bjori@php.net
Reclassified

 [2009-10-12 18:08 UTC] wiesemann@php.net
My last paragraph is wrong: this is not a problem because is per file, not per commit/revision.
 [2013-06-05 17:16 UTC] danbrown@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: danbrown
 [2013-06-05 17:16 UTC] danbrown@php.net
Marking as "not a bug" now, as most things (save for docs) are switched over to 
git now.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Apr 18 18:01:25 2019 UTC