php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #49795 List of methods is incorrect
Submitted: 2009-10-06 19:45 UTC Modified: 2009-11-13 21:23 UTC
From: msjb82 at yahoo dot com Assigned:
Status: Closed Package: Tidy (PECL)
PHP Version: Irrelevant OS: n/a
Private report: No CVE-ID: None
 [2009-10-06 19:45 UTC] msjb82 at yahoo dot com
Description:
------------
List of methods actually shows functions, not the methods from the class.

Reproduce code:
---------------
---
From manual page: http://us2.php.net/manual/en/class.tidy.php
---


Expected result:
----------------
The Tidy class
Introduction

An HTML node in an HTML file, as detected by tidy. 
Class synopsis
Tidy
Tidy {
/* Properties */
/* Methods */
*****
*****These are tidy function, not class methods (the naming
*****convention is even distinct).  Method list here should match
*****method list at bottom of same page.  Remember, this is the
*****class synopsis, not the library synopsis.
*****
tidyNode tidy_get_body ( tidy $object )
bool tidy_clean_repair ( tidy $object )
tidy tidy::__construct ([ string $filename [, mixed $config [, string $encoding [, bool $use_include_path ]]]] )
bool tidy_diagnose ( tidy $object )
array tidy_get_config ( tidy $object )
int tidy_get_html_ver ( tidy $object )
mixed tidy_getopt ( tidy $object , string $option )
string tidy_get_opt_doc ( tidy $object , string $optname )
string tidy_get_release ( void )
int tidy_get_status ( tidy $object )
tidyNode tidy_get_head ( tidy $object )
tidyNode tidy_get_html ( tidy $object )
bool tidy_is_xhtml ( tidy $object )
bool tidy_is_xml ( tidy $object )
tidy tidy_parse_file ( string $filename [, mixed $config [, string $encoding [, bool $use_include_path = false ]]] )
tidy tidy_parse_string ( string $input [, mixed $config [, string $encoding ]] )
string tidy_repair_file ( string $filename [, mixed $config [, string $encoding [, bool $use_include_path = false ]]] )
string tidy_repair_string ( string $data [, mixed $config [, string $encoding ]] )
tidyNode tidy_get_root ( tidy $object )
}
Properties
errorBuffer 

The last warnings and errors from TidyLib 
Table of Contents
tidy::body ? Returns a tidyNode object starting from the tag of the tidy parse tree
tidy::CleanRepair ? Execute configured cleanup and repair operations on parsed markup
tidy::__construct ? Constructs a new tidy object
tidy::diagnose ? Run configured diagnostics on parsed and repaired markup
tidy::getConfig ? Get current Tidy configuration
tidy::htmlver ? Get the Detected HTML version for the specified document
tidy::getOpt ? Returns the value of the specified configuration option for the tidy document
tidy::getoptdoc ? Returns the documentation for the given option name
tidy::getRelease ? Get release date (version) for Tidy library
tidy::getStatus ? Get status of specified document
tidy::head ? Returns a tidyNode object starting from the tag of the tidy parse tree
tidy::html ? Returns a tidyNode object starting from the tag of the tidy parse tree
tidy::isXhtml ? Indicates if the document is a XHTML document
tidy::isXml ? Indicates if the document is a generic (non HTML/XHTML) XML document
tidy::parseFile ? Parse markup in file or URI
tidy::parseString ? Parse a document stored in a string
tidy::repairFile ? Repair a file and return it as a string
tidy::repairString ? Repair a string using an optionally provided configuration file
tidy::root ? Returns a tidyNode object representing the root of the tidy parse tree

Actual result:
--------------
The Tidy class
Introduction

An HTML node in an HTML file, as detected by tidy. 
Class synopsis
Tidy
Tidy {
/* Properties */
/* Methods */
tidyNode tidy_get_body ( tidy $object )
bool tidy_clean_repair ( tidy $object )
tidy tidy::__construct ([ string $filename [, mixed $config [, string $encoding [, bool $use_include_path ]]]] )
bool tidy_diagnose ( tidy $object )
array tidy_get_config ( tidy $object )
int tidy_get_html_ver ( tidy $object )
mixed tidy_getopt ( tidy $object , string $option )
string tidy_get_opt_doc ( tidy $object , string $optname )
string tidy_get_release ( void )
int tidy_get_status ( tidy $object )
tidyNode tidy_get_head ( tidy $object )
tidyNode tidy_get_html ( tidy $object )
bool tidy_is_xhtml ( tidy $object )
bool tidy_is_xml ( tidy $object )
tidy tidy_parse_file ( string $filename [, mixed $config [, string $encoding [, bool $use_include_path = false ]]] )
tidy tidy_parse_string ( string $input [, mixed $config [, string $encoding ]] )
string tidy_repair_file ( string $filename [, mixed $config [, string $encoding [, bool $use_include_path = false ]]] )
string tidy_repair_string ( string $data [, mixed $config [, string $encoding ]] )
tidyNode tidy_get_root ( tidy $object )
}
Properties
errorBuffer 

The last warnings and errors from TidyLib 
Table of Contents
tidy::body ? Returns a tidyNode object starting from the tag of the tidy parse tree
tidy::CleanRepair ? Execute configured cleanup and repair operations on parsed markup
tidy::__construct ? Constructs a new tidy object
tidy::diagnose ? Run configured diagnostics on parsed and repaired markup
tidy::getConfig ? Get current Tidy configuration
tidy::htmlver ? Get the Detected HTML version for the specified document
tidy::getOpt ? Returns the value of the specified configuration option for the tidy document
tidy::getoptdoc ? Returns the documentation for the given option name
tidy::getRelease ? Get release date (version) for Tidy library
tidy::getStatus ? Get status of specified document
tidy::head ? Returns a tidyNode object starting from the tag of the tidy parse tree
tidy::html ? Returns a tidyNode object starting from the tag of the tidy parse tree
tidy::isXhtml ? Indicates if the document is a XHTML document
tidy::isXml ? Indicates if the document is a generic (non HTML/XHTML) XML document
tidy::parseFile ? Parse markup in file or URI
tidy::parseString ? Parse a document stored in a string
tidy::repairFile ? Repair a file and return it as a string
tidy::repairString ? Repair a string using an optionally provided configuration file
tidy::root ? Returns a tidyNode object representing the root of the tidy parse tree

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-11-13 21:23 UTC] vrana@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 [2009-11-13 21:23 UTC] svn@php.net
Automatic comment from SVN on behalf of vrana
Revision: http://svn.php.net/viewvc/?view=revision&revision=290702
Log: Display method names in class definition (bug #49795)
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Nov 29 19:03:12 2021 UTC