php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #49760 Suchfunktion in System ES funktioniert nicht
Submitted: 2009-10-03 16:43 UTC Modified: 2009-10-05 22:26 UTC
From: bracker at 1awww dot com Assigned: danbrown (profile)
Status: Closed Package: Website problem
PHP Version: 5.3.0 OS: *
Private report: No CVE-ID: None
 [2009-10-03 16:43 UTC] bracker at 1awww dot com
Description:
------------
Auf dem Mirror ES funktioniert die Suchfunktion teilweise, teilweise gar nicht.

Reproduce code:
---------------
Auf dem Mirror ES funktioniert die Suchfunktion teilweise, teilweise gar nicht.

Expected result:
----------------
Auf dem Mirror ES funktioniert die Suchfunktion teilweise, teilweise gar nicht.

Actual result:
--------------
Auf dem Mirror ES funktioniert die Suchfunktion teilweise, teilweise gar nicht.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-10-03 16:54 UTC] bjori@php.net
Which mirror is not working? And how exactly isn't it working proberly?
 [2009-10-03 17:03 UTC] bracker at 1awww dot com
Internal error

This mirror does not support searches, please report this error to our webmasters

Searchword: global function
Search in: online documentation

http://es2.php.net/results.php?q=global+function&p=manual&l=de
 [2009-10-03 17:30 UTC] bjori@php.net
Thanks for the headsup.
Until this is fixed you can configure your preferred mirror on http://php.net/my.php

Dan; could you mail the maintainer (probably blocked outbound connection in the firewall)

 [2009-10-03 20:12 UTC] ftp at rediris dot es
Hi,
the mirroring page says:

8<...
Add SQLite Support

SQLite is an embedded SQL database implementation that has very high performance for applications with low write concurrency. PHP mirrors currently employ SQLite for URL shortcut lookups, and will use it for manual page displays and searching in the future.

The SQLite database engine itself is bundled with PHP, and the extension enabled by default with recent PHP releases so there are no additional requirements for mirrors other than standard PHP installation.
Note: Some Linux distributions disable many extensions in their package systems, including SQLite. Please make sure you install the "php5-sqlite" package if using such package system. 
...>8

I think I have sqlite activated... is this the only cause for searches not being working?

regards.
 [2009-10-04 00:20 UTC] philip@php.net
It's probably a "blocked outbound connection in the firewall" which 
means the search is required to access www.php.net to perform the 
search, but this mirror isn't allowing outbound connections.

The exact error is "Unable to find a way to retrieve data with 
file_get_contents" (within the HTML output) and the code that generates 
that lives in here:

http://svn.php.net/viewvc/web/php/trunk/include/site.inc?
revision=278534&view=markup#l201

Summary: Allow outbound connections for the mirror :)
 [2009-10-04 11:40 UTC] ftp at rediris dot es
Port 80 outbound?

I think that's not true:

telnet www.php.net 80
Trying 69.147.83.197...
Connected to y2.php.net.
Escape character is '^]'.
HEAD / HTTP/1.0

HTTP/1.1 200 OK
Date: Sun, 04 Oct 2009 11:37:44 GMT
Server: Apache/1.3.41 (Unix) PHP/5.2.9RC3-dev
X-Powered-By: PHP/5.2.9RC3-dev
Last-Modified: Sun, 04 Oct 2009 10:50:28 GMT
Content-language: en
Set-Cookie: COUNTRY=ESP%2C130.206.1.5; expires=Sun, 11-Oct-2009 11:37:44 GMT; path=/; domain=.php.net
Connection: close
Content-Type: text/html;charset=utf-8

Connection to y2.php.net closed by foreign host.

what else?
 [2009-10-05 13:07 UTC] danbrown@php.net
Jose;

Your mirror is not running SQLite.  If you've recently installed it, 
please remember to restart Apache so that the module loads.  If you need 
help in installing or configuring it, please let us know.

?Gracias, hermano!

    ~ Dan
 [2009-10-05 14:26 UTC] ftp at rediris dot es
Could be the case. I have it enabled:

# grep -i sqlite <somepath>/php5/lib/php.ini
extension=pdo_sqlite.so
extension=sqlite.so
;extension=php_pdo_sqlite.dll
;extension=php_sqlite.dll
[sqlite]
;sqlite.assoc_case = 0

And the server has been re-started many times since this config was in place (the extension is there too, in the extensions directory).

Appart from enabling it in php.ini, any hint to check that it's really enabled? I'd prefer not to turn on 

I tried with php_info(), but the only I see in the page displayed are the compile options...

Any help on this will be welcome!
 [2009-10-05 14:27 UTC] ftp at rediris dot es
Sorry, too many things at the same time... :)

The unfinished word:

"I'd prefer not to turn on debugging"

jose.
 [2009-10-05 15:22 UTC] danbrown@php.net
The easiest way to tell if your mirror is using SQLite is to check the 
mirror-info output:

http://es2.php.net/mirror-info

Note the parameters (at the time of this response):

http://es2.php.net/|5.2.9|1254754272|0|0|es|manual-noalias|1

In order, they are:
Mirror URL
PHP Version
Last-Updated Timestamp
SQLite Version (0 if not enabled)
Stats (Boolean: 0 for False, 1 for True)
Default Language for Mirror (ISO abbreviation)
'manual-noalias' (This is static for now)
rsync Success (Boolean: 0 for False, 1 for True)

As you can see, your mirror is not using SQLite.

From the command line, type:

php -i

Depending on your buffer size, you should be able to scroll back on 
the screen and see the 'sockets' section.  You may also see SPL, if 
available.  Immediately below that, if you have an SQLite section, 
please copy and paste that entire block into this report.

If you can't find it, please type:

php -i > php_bug49760.txt

Then attach that text file to this report.

Thanks!
 [2009-10-05 15:23 UTC] philip@php.net
Although lack of sqlite is a concern, it's not the problem here. See the 
code quoted below. PHP is not being allowed to do what it needs to do.
 [2009-10-05 22:24 UTC] ftp at rediris dot es
Now it works. 

It looks it was a problem with the curl extension. First I did not have it installed, then after installing it, php was complaining about not locating the libntl library needed by the extension; after playing with LD_SO_CONFIG to teach php where this library was, and restarting the server, searches appeared.

Please confirm that everything is normal and the mirror can be listed again.

Thanks everyone for the help!
 [2009-10-05 22:26 UTC] danbrown@php.net
Thanks for your time, both on- and off-list, throughout the day today, 
Jose.  I've verified that searches are once again working on your 
mirror, and it will be reactivated.

bracker (OP): Searches are once again working on this mirror.  Thank you 
for bringing the issue to our attention.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Feb 23 08:01:29 2024 UTC