php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #49746 searching for DOM methods does not work
Submitted: 2009-10-02 09:54 UTC Modified: 2013-08-31 18:51 UTC
Votes:2
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: bz at datenkueche dot com Assigned: bjori (profile)
Status: Closed Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2009-10-02 09:54 UTC] bz at datenkueche dot com
Description:
------------
I'm teaching PHP and we do many things with DOM.

When my students try to get the documentation for
"getElementsByTagName" at http://php.net they get
the PHP4 documentation for
"get_elements_by_tagname".

The php.net search does not know "getElementsByTagName".

My students are not stupid and I told them already how to dearch for DOM PHP5 methods - but they still don't find it.

I already reported this documention bug some years ago but it was marked as "not a bug".

The javascript syntax is nearly the same and I can direct my students to selfhtml but makes not much sense.

Bernhard



Reproduce code:
---------------
http://de.php.net/manual-lookup.php?pattern=getElementsByTagName&lang=en

Expected result:
----------------
http://de.php.net/manual/en/domdocument.getelementsbytagname.php

Actual result:
--------------
http://de.php.net/manual/en/function.domelement-get-elements-by-tagname.php

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-10-02 12:38 UTC] bjori@php.net
Interesting that it doesn't show up there in the search.

However. You can use php.net/classname.methodname
http://php.net/domelement.getelementsbytagname for example works fine
 [2010-03-02 23:19 UTC] jani@php.net
-Summary: searching for DOM Methodes does not work +Summary: searching for DOM methods does not work
 [2013-08-28 08:05 UTC] Laurent dot Lyaudet at gmail dot com
It should be closed. It works now.
 [2013-08-31 18:51 UTC] bjori@php.net
-Status: Verified +Status: Closed -Assigned To: +Assigned To: bjori
 [2013-08-31 18:51 UTC] bjori@php.net
Thanks for the headsup :)
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Oct 19 12:01:27 2019 UTC