php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #49681 Installer throws script error
Submitted: 2009-09-26 15:28 UTC Modified: 2009-09-26 15:56 UTC
From: gohanman at gmail dot com Assigned:
Status: Not a bug Package: Windows Installer
PHP Version: 5.3.0 OS: Vista Home 32
Private report: No CVE-ID: None
 [2009-09-26 15:28 UTC] gohanman at gmail dot com
Description:
------------
Bug is *exactly* what's described in http://bugs.php.net/bug.php?id=47855. That bug claims it's fixed in CVS and will be in the next snapshot; I grabbed the latest available snapshot at http://windows.php.net/snapshots/ and the bug is still there.

Sorry for making another bug report. I couldn't see any way to post onto the other one since it's marked closed.

Reproduce code:
---------------
1. Download installer
2. Run installer
3. Pick apache module

Expected result:
----------------
Installer runs to completetion

Actual result:
--------------
Installer stops with a script error

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-09-26 15:42 UTC] pajoye@php.net
Please try using this snapshot:

  http://snaps.php.net/php5.3-latest.tar.gz
 
For Windows:

  http://windows.php.net/snapshots/


 [2009-09-26 15:49 UTC] gohanman at gmail dot com
That is exactly what I did.

I downloaded this file from windows snapshots:
http://windows.php.net/downloads/snaps/php-5.3-win32-VC6-x86-latest.msi

When I run this file, the same problem occurs as described in bug #47955.
 [2009-09-26 15:53 UTC] pajoye@php.net
What does have reflection to do with the installer? (#47955 is a reflection bug)
 [2009-09-26 15:54 UTC] gohanman at gmail dot com
Typo. I meant 47855 (the bug I referenced in the first post).
 [2009-09-26 15:56 UTC] pajoye@php.net
Reopened #47855, pls follow #47855 instead. No need to duplicate the report.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Feb 25 11:01:27 2024 UTC