php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #49652 FILTER_VALIDATE_EMAIL alllows double -
Submitted: 2009-09-24 10:27 UTC Modified: 2009-09-24 19:50 UTC
From: riad93 at mail dot ru Assigned:
Status: Not a bug Package: Filter related
PHP Version: 5.2.11 OS: *
Private report: No CVE-ID: None
 [2009-09-24 10:27 UTC] riad93 at mail dot ru
Description:
------------
As I know double - are not allowed in domen names and usernames of email

Reproduce code:
---------------
var_dump(filter_var('a--b@m--l.ru',FILTER_VALIDATE_EMAIL));

Expected result:
----------------
bool(false)

Actual result:
--------------
string(12) "a--b@m--l.ru"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-09-24 19:50 UTC] sjoerd@php.net
Thank you for your feedback.

I could not find any specification that disallows consecutive hyphens, and I did find an actual domain name with consecutive hyphens:
http://www.xn--sgarr-wqa3i.com/

I guess it is allowed, so this is not a bug.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Dec 03 17:03:34 2021 UTC