php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #49642 Configure Command reports use hardcoded paths e.g. d:\php-sdk\...
Submitted: 2009-09-23 12:15 UTC Modified: 2009-09-23 13:57 UTC
From: darryn dot kidd at thetrainline dot com Assigned:
Status: Not a bug Package: Windows Installer
PHP Version: 5.2.11 OS: Windows Server 2003
Private report: No CVE-ID: None
 [2009-09-23 12:15 UTC] darryn dot kidd at thetrainline dot com
Description:
------------
I have just installed the non-thread safe version 5.11 using the .msi download. When subsequently loading a php page using phpinfo(), the "Configure Command" has hardcoded paths e.g. with-pdo-oci=D:\php-sdk\oracle\instantclient10\sdk,shared". As our system does not have this folder or drive, I think it is causing problems when trying to load the php_pdo_oci.dll.
When enabling the extension in php.ini i.e. extension=php_pdo_oci.dll, the test page doesn't load (just calling print phpinfo) and the server event system reports the problem "Unable to load dynamic link library 'C:\PHP\ext\php_pdo_oci.dll' - The specified procedure could not be found." 
I have checked that the file is there, and that the php.ini directs my extensions to the ext directory, so I can only think that it now has a problem finding the correct client to use, which looks like it is hard-coded in the "Configure Command".
Can the hard-coded paths be removed from the installer package, or is there another method to make php connect to the correct oracle client.

Thanks,
Darryn

Reproduce code:
---------------
print phpinfo()


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-09-23 13:37 UTC] pajoye@php.net
That has nothing to do with your problem. This command is used to configure the compilation of PHP on windows.

You have to install the InstantClient to use the OCI extensions.
 [2009-09-23 13:57 UTC] darryn dot kidd at thetrainline dot com
I have the full oracle client installed on the server, with the ora_home path registered in the environment path. How do I get PHP to find and use the oci.dll in my oracle\bin directory? Do I still need to load the instant client as well as having the full client installed?
I am also getting the same message when enabling php_pdo_mssql.dll or php_mssql.dll, which also have the relevant path variables entered, so PHP isn't finding these libraries either.

How do I get PHP to look for the database client libraries, where the relevant paths are stored in the Environment Paths?

Thanks
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Feb 25 13:01:27 2024 UTC