php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #496 using variable by reference in object functions sometimes crashes PHP
Submitted: 1998-07-01 09:55 UTC Modified: 1998-09-22 05:56 UTC
From: auke at snt dot utwente dot nl Assigned: zeev (profile)
Status: Closed Package: Reproducible Crash
PHP Version: 3.0 Final Release OS: Linux (redhat 4)
Private report: No CVE-ID: None
 [1998-07-01 09:55 UTC] auke at snt dot utwente dot nl
Unfortunately I haven't yet found a _short_ script that reproduces
the bug. It seems it will only crash in special cases in which you
have a minimum number of included files and functions... still
trying to get it to the minimum crashsize :)

But so far the problem is:
script a includes a file b with function c
file b includes a file d with class description e
function c creates a new object f of class e and returns it.

now PHP will crash when it creates this object if it has a function 
that takes a variable by reference. But _only_ when I have included
some other files as wel.. (which don't have anything to do with the
code that produces the crash...)

sorry if this sounds vage, I'm still trying to find a minimal script..
if I don't succeed I'll just have to send the whole bunch i guess..

(BTW,is there anyway to update this bugreport later?)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-09-22 05:56 UTC] zeev
I believe this has been fixed already.  Did you happen to
post a followup that got solved?
Can you check out if it still happens in 3.0.3?

---
No response from the user.  This bug should be fixed
by now.  If it isn't, please submit a new bug report.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue May 21 22:01:26 2019 UTC