php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #49578 make install-pear fails
Submitted: 2009-09-17 10:36 UTC Modified: 2009-09-17 11:41 UTC
From: mamfelt at gmail dot com Assigned: bjori
Status: Closed Package: Compile Failure
PHP Version: 5.2.10 OS: AIX 6.1.3
Private report: No CVE-ID:
 [2009-09-17 10:36 UTC] mamfelt at gmail dot com
Description:
------------
after getting the flags right for a straight forward configure and make, make install-pear fails.

code snippet: no fix!
line 64 through 66:
$ctx = stream_context_create($copt, array("notification" => "stream_notification_callback"));

$fp = fopen($argv[1], "r", false, $ctx);

AIX 6.1.3, xlC compiler (v7)



Reproduce code:
---------------
export LIBPATH=/usr/lib:/usr/local/ssl/lib:/usr/local/lib:/usr/vac/lib:/usr/vacpp/lib
./configure \
        --enable-safe-mode --enable-magic-quotes \
        --with-openssl=/usr/local/ssl \
        --with-zlib-dir=/data/prj/zlib-1.2.3 \
        --disable-bcmath \
        --enable-dba  --enable-ftp \
        --with-gd     --with-jpeg-dir=/usr/local/lib  \
        --with-ttf    --with-curlwrappers \
        --with-curl   --with-freetype-dir \
        --enable-gd-native-ttf \
        --with-mysql=/usr/local/mysql \
        --with-pear=/usr/local/bin
make
make install

Expected result:
----------------
installed php

Actual result:
--------------
michael@x054:[/data/home/michael/prj/php5.2-200909161430]make install
Installing PHP SAPI module:       cgi
Installing PHP CGI binary: /usr/local/bin/
Installing PHP CLI binary:        /usr/local/bin/
Installing PHP CLI man page:      /usr/local/man/man1/
Installing build environment:     /usr/local/lib/php/build/
Installing header files:          /usr/local/include/php/
Installing helper programs:       /usr/local/bin/
  program: phpize
  program: php-config
Installing man pages:             /usr/local/man/man1/
  page: phpize.1
  page: php-config.1
Installing PEAR environment:      /usr/local/bin/

Warning: stream_context_create() expects at most 1 parameter, 2 given in /data/prj/php5.2-200909161430/pear/fetch.php on line 64

Warning: fopen() expects parameter 4 to be resource, boolean given in /data/prj/php5.2-200909161430/pear/fetch.php on line 66

Error..
fopen() expects parameter 4 to be resource, boolean given
make: *** [install-pear] Error 1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-09-17 11:01 UTC] jani@php.net
Those flags aren't quite right. There isn't any options in the (--with|--enable) family in PHP configure which expects you to give any paths to /xxx/lib ( /usr/local/lib should be /usr/local )

But it's not the reason pear install fails, that's more inherent problem with bad design in how pear is installed from some obscure phar thing. Assigned to maintainer.
 [2009-09-17 11:04 UTC] jani@php.net
Change the assigned to, according to Pierre, Greg is responsible for this part.
 [2009-09-17 11:05 UTC] jani@php.net
Change the assigned to, according to Pierre, Greg is responsible for this part.
 [2009-09-17 11:11 UTC] bjori@php.net
This is actually my fault.
Quick fix: install 'wget'.
 [2009-09-17 11:19 UTC] mamfelt at gmail dot com
I can edit my config file. I have used, updated this command since php 4.4.X - at least on AIX they were needed.

For some reason, ./configure does not find the jpeg things unless I give the path.

Background info - not releated to the bug I hope -

It is quite confusing between different versions of AIX as AIX also has a libssl.a and libcrypt.a (with a .so file in them) while the libraries I am building my self are filled with the .o files.

When I compiled on AIX 5.2 and 5.3 (before the libs I just mentioned were in /usr/lib) I did not need to export the LIBPATH before I built any packages. getting curl to load properly as a shared library has forced me to do this - otherwise the libcurl does not load.

I suspect it has to do with libtool not being up to date for AIX - that used to be the magic wand for PHP (4.0.X versions).

And, I am wondering if I need to check flags for the openssl package I also compile myself.

===
Closing: if there is a new configure command you would like me to run, just post, or mail, and I'll run it as soon as I can.
Just let me know (link please) if you want me to use a new snap, or stay with this one.
 [2009-09-17 11:36 UTC] svn@php.net
Automatic comment from SVN on behalf of bjori
Revision: http://svn.php.net/viewvc/?view=revision&revision=288404
Log: Fixed bug#49578 (make install-pear fails)
# Apparently this script was using 5.3 functionality
# Workaround would be to install 'wget'
 [2009-09-17 11:41 UTC] bjori@php.net
This bug has been fixed in SVN.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.

The make install-pear problem has been fixed.

 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sat Apr 19 06:02:27 2014 UTC