php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #49332 Make fails with "Undefined symbols: _res_9_dn_expand, _res_9_search and _res_9"
Submitted: 2009-08-23 03:31 UTC Modified: 2009-10-16 16:10 UTC
Votes:16
Avg. Score:4.9 ± 0.3
Reproduced:15 of 15 (100.0%)
Same Version:13 (86.7%)
Same OS:15 (100.0%)
From: vizh at me dot com Assigned: scottmac
Status: Closed Package: Compile Failure
PHP Version: 5.2.10 OS: Mac OS X 10.6 (10A432)
Private report: No CVE-ID:
 [2009-08-23 03:31 UTC] vizh at me dot com
Description:
------------
I've download http://snaps.php.net/php5.2-latest.tar.gz, runs 
./configure; make and make fails with undefined symbols: 
_res_9_dn_expand, _res_9_search and _res_9_dn_skipname

Reproduce code:
---------------
cd /tmp
curl "http://snaps.php.net/php5.2-latest.tar.gz" > php.tar.gz
tar -xf php.tar.gz; rm -rf php.tar.gz; mv php* php-build; cd php-build
./configure --disable-all
make

Actual result:
--------------
Undefined symbols:
  "_res_9_search", referenced from:
      _zif_dns_get_mx in dns.o
      _zif_dns_check_record in dns.o
  "_res_9_dn_expand", referenced from:
      _zif_dns_get_mx in dns.o
  "_res_9_dn_skipname", referenced from:
      _zif_dns_get_mx in dns.o
      _zif_dns_get_mx in dns.o

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-08-23 11:31 UTC] scottmac@php.net
This is fixed in 5.3.1-dev, I'll look into backporting changes to the 5.3 branch.
 [2009-08-24 14:43 UTC] jani@php.net
I would guess Scott meant "PHP_5_2" branch.. :)
 [2009-08-26 00:51 UTC] djem dot v3 at gmail dot com
Since php 5.3 has been preinstalled in Snow Leopard, it is very 
important to have php 5.2 in system.
 [2009-09-07 05:18 UTC] tmallen at 703designs dot com
Here's a temporary fix: http://trac.macports.org/ticket/19997
 [2009-09-26 22:56 UTC] philip@php.net
Another temp fix: Add -lresolv to EXTRA_LIBS in the generated MakeFile. 
See also: http://bit.ly/SJ3YQ
 [2009-10-16 16:09 UTC] svn@php.net
Automatic comment from SVN on behalf of scottmac
Revision: http://svn.php.net/viewvc/?view=revision&revision=289700
Log: Fix bug #49332 - Unable to compile with Snow Leopard due to some DNS funsies
 [2009-10-16 16:10 UTC] scottmac@php.net
This bug has been fixed in SVN.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 [2012-12-22 02:01 UTC] g dot fischer at ah-online dot com
just ran into this issue with 5.3.20, 5.5.0a2 and trunk. seems not fixed.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sun Apr 20 01:02:05 2014 UTC