php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #4925 .htaccess problem with custom 401 ErrorDocument (Apache 1.3.12, PHP 4.0.0)
Submitted: 2000-06-09 09:34 UTC Modified: 2004-09-03 18:01 UTC
From: tapio dot ryhanen at oulu dot fi Assigned: zak (profile)
Status: Closed Package: *General Issues
PHP Version: 4.0.0 Release OS: Redhat 6.0 with kernel 2.2.16
Private report: No CVE-ID: None
 [2000-06-09 09:34 UTC] tapio dot ryhanen at oulu dot fi
As soon as I specify 

ErrorDocument 401 /error.html 

for my virtual server, I can't log into a secured directory under it using .htaccess/htpasswd, I get an error page instead.

I've specified other Errodocs for 403/404/500, etc. and I can log in fine with 
the username/password prompt for http://www.virtualhost.com/foo/ but as soon 
as I add the ErrorDocument 401 /error.html for virtualhost.com in httpd.conf I 
get an error message when I goto http://www.virtualhost.com/foo/ instead of 
the user/pass box.

I'm using Apache 1.3.12 with PHP 4.0.0 on Linux 2.2.16.

Specifying custom errordocs worked just fine with php version 3.0.15 and Apache 1.3.12. After upgrading to PHP v. 4.0.0 custom errordocs no longer work. Any ideas?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-26 20:20 UTC] zak@php.net
I will try to confirm this bug.
 [2000-08-23 18:26 UTC] zak@php.net
Henryk Pl?tz (HenrykPloetz@gmx.de) was kind enough to confirm this bug for me.

Here is his message
-------------------
I've encountered this same problem myself and it seems to be a general issue with PHP4 and ErrorDocuments. 
I've tried it under Linux kernel 2.2.14 with Apache 1.3.12 and PHP 4.0.1pl2 as well as with SunOS 5.7, Apache 1.3.12 and PHP 4.0.0. 

When specifying an ErrorDocument to be parsed by PHP the returned HTTP-Status-Code is changed to 200 OK regardless of its previous  value.

This causes the browser to not display any password dialogue.

The same happens with every other Status-Code (I've tried 401, 404 and 500) which all end up to be sent and logged as 200 OK.
 [2000-11-08 18:48 UTC] sniper@php.net
Does this still happen with latest snapshot from http://snaps.php.net ??

--Jani
 [2000-12-07 11:15 UTC] sniper@php.net
No feedback.
 [2004-09-03 18:01 UTC] mfischer@php.net
This bug has been fixed in 4.0.2
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Sun Oct 21 01:01:26 2018 UTC