php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #49215 make fails on glob_wrapper
Submitted: 2009-08-11 02:32 UTC Modified: 2010-09-10 23:33 UTC
Votes:10
Avg. Score:4.8 ± 0.6
Reproduced:8 of 8 (100.0%)
Same Version:5 (62.5%)
Same OS:3 (37.5%)
From: jim dot stcyr at gmail dot com Assigned: felipe
Status: Closed Package: Compile Failure
PHP Version: 5.3SVN-2009-08-11 (snap) OS: RedHat 2.6.9-89.0.3.ELsmp
Private report: No CVE-ID:
 [2009-08-11 02:32 UTC] jim dot stcyr at gmail dot com
Description:
------------
./configure \
--with-apxs2=/usr/local/apache2.2/bin/apxs \
--with-oci8=instantclient,/home/instantclient \
--enable-sigchild

./make

/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c:40: error: syntax error before "glob_t"
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c:40: warning: no semicolon at end of struct or uni                                    on
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c:41: error: 'index' redeclared as different kind o                                    f symbol
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c:41: error: 'index' redeclared as different kind o                                    f symbol
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c:47: error: syntax error before '}' token
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c:47: warning: data definition has no type or stora                                    ge class
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c: In function `_php_glob_stream_get_path':
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c:51: error: `pglob' undeclared (first use in this                                     function)
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c:51: error: (Each undeclared identifier is reporte                                    d only once
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c:51: error: for each function it appears in.)
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c:51: error: syntax error before ')' token
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c: In function `_php_glob_stream_get_pattern':
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c:73: error: `pglob' undeclared (first use in this                                     function)
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c:73: error: syntax error before ')' token
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c: In function `_php_glob_stream_get_count':
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c:95: error: `pglob' undeclared (first use in this                                     function)
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c:95: error: syntax error before ')' token
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c: At top level:
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c:111: error: syntax error before '*' token
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c: In function `php_glob_stream_path_split':
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c:124: error: `p_file' undeclared (first use in thi                                    s function)
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c:126: error: `get_path' undeclared (first use in t                                    his function)
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c:127: error: `pglob' undeclared (first use in this                                     function)
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c: In function `php_glob_stream_read':
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c:141: error: `pglob' undeclared (first use in this                                     function)
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c:141: error: syntax error before ')' token
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c:148: error: `GLOB_APPEND' undeclared (first use i                                    n this function)
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c: In function `php_glob_stream_close':
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c:165: error: `pglob' undeclared (first use in this                                     function)
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c:165: error: syntax error before ')' token
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c: In function `php_glob_stream_rewind':
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c:184: error: `pglob' undeclared (first use in this                                     function)
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c:184: error: syntax error before ')' token
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c: In function `php_glob_stream_opener':
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c:211: error: `pglob' undeclared (first use in this                                     function)
/home/automan/php5.3-200908110030/main/streams/glob_wrapper.c:251: error: `GLOB_APPEND' undeclared (first use i                                    n this function)
make: *** [main/streams/glob_wrapper.lo] Error 1



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-08-11 09:27 UTC] jani@php.net
Exactly what linux distro are you using? And does this work:

# rm -f config.cache ; ./configure --disable-all --disable-cgi && make

 [2009-08-11 13:50 UTC] jim dot stcyr at gmail dot com
The linux version this is running on is RedHat Enterprise Linux.  I believe it's version 4. 
 
Running:
[root@les1 php5.3-200908110030]# rm -f config.cache ; ./configure --disable-all --disable-cgi && make

resulted in:

/bin/sh /home/automan/php5.3-200908110030/libtool --silent --preserve-dup-deps --mode=link gcc -export-dynamic -g -O2     ext/date/php_date.lo ext/date/lib/astro.lo ext/date/lib/dow.lo ext/date/lib/parse_date.lo ext/date/lib/parse_tz.lo ext/date/lib/timelib.lo ext/date/lib/tm2unixtime.lo ext/date/lib/unixtime2tm.lo ext/date/lib/parse_iso_intervals.lo ext/date/lib/interval.lo ext/ereg/ereg.lo ext/ereg/regex/regcomp.lo ext/ereg/regex/regexec.lo ext/ereg/regex/regerror.lo ext/ereg/regex/regfree.lo ext/pcre/pcrelib/pcre_chartables.lo ext/pcre/pcrelib/pcre_ucd.lo ext/pcre/pcrelib/pcre_compile.lo ext/pcre/pcrelib/pcre_config.lo ext/pcre/pcrelib/pcre_exec.lo ext/pcre/pcrelib/pcre_fullinfo.lo ext/pcre/pcrelib/pcre_get.lo ext/pcre/pcrelib/pcre_globals.lo ext/pcre/pcrelib/pcre_info.lo ext/pcre/pcrelib/pcre_maketables.lo ext/pcre/pcrelib/pcre_newline.lo ext/pcre/pcrelib/pcre_ord2utf8.lo ext/pcre/pcrelib/pcre_refcount.lo ext/pcre/pcrelib/pcre_study.lo ext/pcre/pcrelib/pcre_tables.lo ext/pcre/pcrelib/pcre_try_flipped.lo ext/pcre/pcrelib/pcre_valid_utf8.lo ext/pcre/pcrelib/pcre_version.lo ext/pcre/pcrelib/pcre_xclass.lo ext/pcre/php_pcre.lo ext/reflection/php_reflection.lo ext/spl/php_spl.lo ext/spl/spl_functions.lo ext/spl/spl_engine.lo ext/spl/spl_iterators.lo ext/spl/spl_array.lo ext/spl/spl_directory.lo ext/spl/spl_exceptions.lo ext/spl/spl_observer.lo ext/spl/spl_dllist.lo ext/spl/spl_heap.lo ext/spl/spl_fixedarray.lo ext/standard/crypt_freesec.lo ext/standard/crypt_blowfish.lo ext/standard/php_crypt_r.lo ext/standard/array.lo ext/standard/base64.lo ext/standard/basic_functions.lo ext/standard/browscap.lo ext/standard/crc32.lo ext/standard/crypt.lo ext/standard/cyr_convert.lo ext/standard/datetime.lo ext/standard/dir.lo ext/standard/dl.lo ext/standard/dns.lo ext/standard/exec.lo ext/standard/file.lo ext/standard/filestat.lo ext/standard/flock_compat.lo ext/standard/formatted_print.lo ext/standard/fsock.lo ext/standard/head.lo ext/standard/html.lo ext/standard/image.lo ext/standard/info.lo ext/standard/iptc.lo ext/standard/lcg.lo ext/standard/link.lo ext/standard/mail.lo ext/standard/math.lo ext/standard/md5.lo ext/standard/metaphone.lo ext/standard/microtime.lo ext/standard/pack.lo ext/standard/pageinfo.lo ext/standard/quot_print.lo ext/standard/rand.lo ext/standard/soundex.lo ext/standard/string.lo ext/standard/scanf.lo ext/standard/syslog.lo ext/standard/type.lo ext/standard/uniqid.lo ext/standard/url.lo ext/standard/var.lo ext/standard/versioning.lo ext/standard/assert.lo ext/standard/strnatcmp.lo ext/standard/levenshtein.lo ext/standard/incomplete_class.lo ext/standard/url_scanner_ex.lo ext/standard/ftp_fopen_wrapper.lo ext/standard/http_fopen_wrapper.lo ext/standard/php_fopen_wrapper.lo ext/standard/credits.lo ext/standard/css.lo ext/standard/var_unserializer.lo ext/standard/ftok.lo ext/standard/sha1.lo ext/standard/user_filters.lo ext/standard/uuencode.lo ext/standard/filters.lo ext/standard/proc_open.lo ext/standard/streamsfuncs.lo ext/standard/http.lo TSRM/TSRM.lo TSRM/tsrm_strtok_r.lo TSRM/tsrm_virtual_cwd.lo main/main.lo main/snprintf.lo main/spprintf.lo main/php_sprintf.lo main/safe_mode.lo main/fopen_wrappers.lo main/alloca.lo main/php_scandir.lo main/php_ini.lo main/SAPI.lo main/rfc1867.lo main/php_content_types.lo main/strlcpy.lo main/strlcat.lo main/mergesort.lo main/reentrancy.lo main/php_variables.lo main/php_ticks.lo main/network.lo main/php_open_temporary_file.lo main/php_logos.lo main/output.lo main/getopt.lo main/streams/streams.lo main/streams/cast.lo main/streams/memory.lo main/streams/filter.lo main/streams/plain_wrapper.lo main/streams/userspace.lo main/streams/transports.lo main/streams/xp_socket.lo main/streams/mmap.lo main/streams/glob_wrapper.lo Zend/zend_language_parser.lo Zend/zend_language_scanner.lo Zend/zend_ini_parser.lo Zend/zend_ini_scanner.lo Zend/zend_alloc.lo Zend/zend_compile.lo Zend/zend_constants.lo Zend/zend_dynamic_array.lo Zend/zend_execute_API.lo Zend/zend_highlight.lo Zend/zend_llist.lo Zend/zend_opcode.lo Zend/zend_operators.lo Zend/zend_ptr_stack.lo Zend/zend_stack.lo Zend/zend_variables.lo Zend/zend.lo Zend/zend_API.lo Zend/zend_extensions.lo Zend/zend_hash.lo Zend/zend_list.lo Zend/zend_indent.lo Zend/zend_builtin_functions.lo Zend/zend_sprintf.lo Zend/zend_ini.lo Zend/zend_qsort.lo Zend/zend_multibyte.lo Zend/zend_ts_hash.lo Zend/zend_stream.lo Zend/zend_iterators.lo Zend/zend_interfaces.lo Zend/zend_exceptions.lo Zend/zend_strtod.lo Zend/zend_gc.lo Zend/zend_closures.lo Zend/zend_float.lo Zend/zend_objects.lo Zend/zend_object_handlers.lo Zend/zend_objects_API.lo Zend/zend_default_classes.lo Zend/zend_execute.lo sapi/cli/php_cli.lo sapi/cli/php_cli_readline.lo main/internal_functions_cli.lo -lcrypt -lresolv -lcrypt -lm -ldl -lnsl -lcrypt -lcrypt  -o sapi/cli/php
ext/standard/.libs/basic_functions.o(.text+0x7c2): In function `zm_shutdown_basic':
/home/automan/php5.3-200908110030/ext/standard/basic_functions.c:3686: undefined reference to `zm_shutdown_crypt'
collect2: ld returned 1 exit status
make: *** [sapi/cli/php] Error 1
 [2009-08-11 19:01 UTC] jani@php.net
# make clean && make 

..and what compiler are you using? Version?

 [2009-08-11 20:29 UTC] jim dot stcyr at gmail dot com
What's really irritating about this issue is that PHP has been successfully built on this machine in the past; as recently as last month.  

[automan@les1 ~]$ gcc -v
Reading specs from /usr/lib/gcc/i386-redhat-linux/3.4.6/specs
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-threads=posix --disable-checking --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-java-awt=gtk --host=i386-redhat-linux
Thread model: posix
gcc version 3.4.6 20060404 (Red Hat 3.4.6-11)
 [2009-08-12 09:03 UTC] jani@php.net
Can you try the PHP_5_2 snapshot also:

  http://snaps.php.net/php5.2-latest.tar.gz

And are you absolutely sure nothing has changed in your system..?
I suggest trying to recompile the last PHP version you were able to build before..


 [2009-08-20 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2009-11-19 01:58 UTC] lcmattoso at hotmail dot com
Try just 
rm -f config.cache
and your old ./configure params
works for me
 [2010-05-09 23:20 UTC] felipe@php.net
-Status: No Feedback +Status: Feedback
 [2010-05-09 23:20 UTC] felipe@php.net
Please try using this snapshot:

  http://snaps.php.net/php5.3-latest.tar.gz
 
For Windows:

  http://windows.php.net/snapshots/


 [2010-09-01 11:50 UTC] damien dot gerard at sgcib dot com
Still got the same problem with last snapshot:

php5.3-201009010830/main/streams/glob_wrapper.c:40: error: expected specifier-qualifier-list before 'glob_t'

Red Hat Enterprise Linux Server release 5.4 (Tikanga)
gcc version 4.1.2 20080704 (Red Hat 4.1.2-46)
 [2010-09-01 12:09 UTC] aharvey@php.net
-Status: Feedback +Status: Open
 [2010-09-10 23:33 UTC] felipe@php.net
Automatic comment from SVN on behalf of felipe
Revision: http://svn.php.net/viewvc/?view=revision&revision=303265
Log: - Fixed bug #49215 (make fails on glob_wrapper)
 [2010-09-10 23:33 UTC] felipe@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: felipe
 [2010-09-10 23:33 UTC] felipe@php.net
This bug has been fixed in SVN.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 23 18:01:55 2014 UTC