php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #49199 when i use microsoft ado to insert data ,there has a bug
Submitted: 2009-08-09 04:05 UTC Modified: 2009-08-17 01:00 UTC
From: lzt dot liang at tom dot com Assigned:
Status: No Feedback Package: COM related
PHP Version: 5.2.10 OS: window xp and 2003
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2009-08-09 04:05 UTC] lzt dot liang at tom dot com
Description:
------------
microsoft com in ado has a bug

Reproduce code:
---------------
<?php
$conn=new COM("adodb.connection");
$conn->open("provider=sqloledb;data source=192.168.0.2,1433;User ID=sa;pwd=123;Initial Catalog=tmp");

$rs=new COM("ADODB.Recordset");
$sql="SELECT * FROM [dbo].[tmp]";
$rs->open($sql,$conn,1,3);
$rs->addnew;
$rs["text"]="???ΤΏ???";
$rs->update;
?>

Expected result:
----------------
please see this pic
http://www.gdlydf.com/longyan/Image/2009080717103050286.jpg


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-08-09 14:49 UTC] jani@php.net
I don't even know what language that might be. So what exactly is the 
expected and what is the actual result you get? 
 [2009-08-17 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Nov 30 17:05:53 2022 UTC