php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #4898 Session management fails
Submitted: 2000-06-08 14:52 UTC Modified: 2000-07-18 06:34 UTC
From: fvddungen at netgamez dot nl Assigned:
Status: Closed Package: Session related
PHP Version: 4.0.0 Release OS: Windows NT
Private report: No CVE-ID: None
 [2000-06-08 14:52 UTC] fvddungen at netgamez dot nl
I have discovered a very strange thing. First I thought it was only me and I posted the problem on phpbuilder.com, but then it seemed that many other people are having the same problem.

The problem is that session management in php4 on a windows machine fails to work when using the php4isapi.dll. 
Till the last beta the session management worked without any problems, but from the rc1, so also the rc2 and the final release session management just refuses to work. As soon as the browser requests a file with a session_start or session_register command the browser gets in a kinda endless loop. The browser keeps waiting and waiting and nothing happens (nothing appears on the screen).
If I change php4isapi.dll into php.exe in my iis settings it works, but that will decrease the performance, right.

As I said, until the last beta it worked fine, but from the first release candidate it didn't work anymore.

And since many people are having this same problem I guess it's a major bug, right.

With regards

Frank

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-06-09 13:15 UTC] hholzgra at cvs dot php dot net
changed to "Session related"
 [2000-07-18 06:34 UTC] stas at cvs dot php dot net
Please try 4.0.1pl2 and report (with script example) if it still doesn't work.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Feb 04 15:04:09 2023 UTC