php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48894 Occasional crashes with Apache 1.3.41
Submitted: 2009-07-12 20:08 UTC Modified: 2013-06-27 23:01 UTC
Votes:3
Avg. Score:3.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:1 (50.0%)
From: php at anders dot fupp dot net Assigned: yohgaki (profile)
Status: Closed Package: Apache related
PHP Version: 5.2.10 OS: FreeBSD/amd64 7.2-RELEASE
Private report: No CVE-ID: None
 [2009-07-12 20:08 UTC] php at anders dot fupp dot net
Description:
------------
Apache 1.3.41 crashes now and then due to problems in PHP 5.2.10 mod_php module:

Jul 12 18:44:59 master kernel: pid 58886 (httpd), uid 80: exited on signal 10 (core dumped)
Jul 12 19:06:31 master kernel: pid 60864 (httpd), uid 80: exited on signal 10 (core dumped)
Jul 12 19:08:30 master kernel: pid 61302 (httpd), uid 80: exited on signal 11 (core dumped)
Jul 12 20:27:43 master kernel: pid 67077 (httpd), uid 80: exited on signal 11 (core dumped)
Jul 12 20:50:14 master kernel: pid 69216 (httpd), uid 80: exited on signal 11 (core dumped)
Jul 12 21:07:00 master kernel: pid 71457 (httpd), uid 80: exited on signal 10 (core dumped)
Jul 12 21:10:18 master kernel: pid 70542 (httpd), uid 80: exited on signal 11 (core dumped)
Jul 12 21:38:28 master kernel: pid 77041 (httpd), uid 80: exited on signal 11 (core dumped)

I use these extensions:

php5-ctype-5.2.10
php5-curl-5.2.10
php5-dom-5.2.10
php5-gd-5.2.10
php5-gettext-5.2.10
php5-iconv-5.2.10
php5-imap-5.2.10
php5-mbstring-5.2.10
php5-mcrypt-5.2.10
php5-mhash-5.2.10
php5-mysql-5.2.10
php5-openssl-5.2.10
php5-pcre-5.2.10
php5-posix-5.2.10
php5-pspell-5.2.10
php5-session-5.2.10
php5-simplexml-5.2.10
php5-spl-5.2.10
php5-tokenizer-5.2.10
php5-xml-5.2.10
php5-zlib-5.2.10

Also, I have gd 2.0.35 and imap-uw 2007e installed.

Reproduce code:
---------------
N/A. It happens occasionally. I run one fairly big WordPress site (http://neppe.no/) and a forum on http://motorpsycho.fix.no. But I can't find out exactly what provokes the crash.


Actual result:
--------------
GDB backtrace:

(gdb) bt full
#0  0x00000000004249e4 in ap_rflush (r=0x805d61c38) at http_protocol.c:2823
No locals.
#1  0x0000000801c92efc in sapi_apache_flush (server_context=0x805d61c38)
    at /usr/ports/lang/php5/work/php-5.2.10/sapi/apache/mod_php5.c:119
No locals.
#2  0x0000000801bc652f in sapi_flush ()
    at /usr/ports/lang/php5/work/php-5.2.10/main/SAPI.c:922
No locals.
#3  0x0000000801bbbb6d in php_module_shutdown ()
    at /usr/ports/lang/php5/work/php-5.2.10/main/main.c:1906
        module_number = 0
#4  0x0000000801bbbb31 in php_module_shutdown_wrapper (
    sapi_globals=0x801e43c00)
    at /usr/ports/lang/php5/work/php-5.2.10/main/main.c:1879
No locals.
#5  0x0000000801c945c0 in php_child_exit_handler (s=0x800b05060, p=0x800b31018)
    at /usr/ports/lang/php5/work/php-5.2.10/sapi/apache/mod_php5.c:928
No locals.
#6  0x00000000004119f0 in ap_child_exit_modules (p=0x800b31018, s=0x800b05060)
    at http_config.c:1634
        m = (module *) 0x801e43d20
#7  0x0000000000419df6 in clean_child_exit (code=0) at http_main.c:542
No locals.
#8  0x000000000041d16a in child_main (child_num_arg=5) at http_main.c:4633
        conn_io = (BUFF *) 0x805dcb080
        r = (request_rec *) 0x805d60060
        clen = 16
        sa_server = {sa_len = 16 '\020', sa_family = 2 '\002', 
  sa_data = "\000PP[$\024\000\000\000\000\000\000\000"}
        sa_client = {sa_len = 16 '\020', sa_family = 2 '\002', 
  sa_data = "\b?W\232?\027\000\000\000\000\000\000\000"}
        lr = (listen_rec *) 0x0
#9  0x000000000041d734 in make_child (s=0x800b05060, slot=5, now=1247427429)
    at http_main.c:5055
        pid = 0
#10 0x000000000041db6b in perform_idle_server_maintenance ()
    at http_main.c:5256
        i = 0
        to_kill = 1
        idle_count = 2
        pid = -1
        ss = (short_score *) 0x80058e410
        now = 1247427429
        free_length = 1
        free_slots = {5, 6, 10, 11, 16, 17, 18, 19, -4976, 32767, 4305748, 0, 
  98677480, 8, 4451364, 0, -4960, 32767, 4254904, 0, 5824512, 8, 1, 0, -4912, 
  32767, 4305748, 0, -4912, 32767, 4316501, 4}
        last_non_dead = 4
        total_non_dead = 5
---Type <return> to continue, or q <return> to quit---
        reported = 0
#11 0x000000000041e159 in standalone_main (argc=1, argv=0x7fffffffee20)
    at http_main.c:5520
        child_slot = 0
        status = -256
        pid = -1
        remaining_children_to_start = 0
#12 0x000000000041e7a4 in main (argc=1, argv=0x7fffffffee20)
    at http_main.c:5773
        c = -1
        sock_in = -4608
        sock_out = 32767
        s = 0x7fffffffef68 "httpd"
(gdb) 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-07-12 20:13 UTC] php at anders dot fupp dot net
Someone report this as an Apache bug, which was closed in their bug tracking system: https://issues.apache.org/bugzilla/show_bug.cgi?id=47070
 [2009-07-15 12:14 UTC] jani@php.net
Note: There is good analysis on that Apache bug what the problem is. 
Workaround: Use lighttpd + PHP-fcgi :)
 [2009-07-17 09:06 UTC] php at anders dot fupp dot net
Yes, the Apache ticket specifically mentions that the bug is in the caller, which is PHP. Are you or anyone going to look at this other than keep pointing at Apache or suggesting alternatives? I submitted this ticket to possibly have the problem fixed, that is the only reason I bothered to do it. It's annoying to keep have to mentioning where the problem (probably) is, I start to wonder whether it is useful to submit tickets at bugs.php.net at all.
 [2009-07-22 20:30 UTC] jani@php.net
I only pointed at the fact that there is more detailed information on 
that Apache bug ticket you mentioned. I'm not pointing any fingers 
anywhere, this is PHP bug for sure. 
 [2009-07-28 11:58 UTC] php at anders dot fupp dot net
I just wanted to tell that I've upgraded to Apache 2.2.11 (ITK), and since then I have not had these problems anymore. So it seems to be an issue with Apache 1.3.)
 [2013-06-27 23:01 UTC] yohgaki@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: yohgaki
 [2013-06-27 23:01 UTC] yohgaki@php.net
Apache problem.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed May 18 07:05:45 2022 UTC