php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48787 session_set_save_handler: can't find previously included class in write func
Submitted: 2009-07-03 14:20 UTC Modified: 2009-07-07 17:26 UTC
From: pietro dot baldassarri at unibo dot it Assigned:
Status: Not a bug Package: Session related
PHP Version: 5.2.10 OS: Gentoo Linux
Private report: No CVE-ID: None
 [2009-07-03 14:20 UTC] pietro dot baldassarri at unibo dot it
Description:
------------
PHP can't find a previously included class in user defined session write callback function. Class is used without any problem in open and read processes. 
The code works like a charme using PHP v. 5.2.9

Reproduce code:
---------------
http://137.204.215.224/bug/code.txt

Expected result:
----------------
Accessing Logger::log() method in each session's user defined callback functions to append dato to log file 
/tmp/debug.log content:
***************************   OPENING   ***************************
*************************** READING ***************************
*************************** WRITING ***************************
Done


Actual result:
--------------
/tmp/debug.log content:
***************************   OPENING   ***************************
*************************** READING ***************************


PHP Fatal error:  Class 'Logger' not found in /home/petrux/workspace/debug10/Session.php on line 41

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-07-06 12:41 UTC] jani@php.net
Do you have any 3rd party extensions, zend extensions like APC installed and enabled?
 [2009-07-06 16:42 UTC] pietro dot baldassarri at unibo dot it
I could reproduce the error with all the extension disabled with version 5.2.10 but with version 5.2.10-r1 (just upgraded) everithing works fine also with apc and xdebug enabled.
 [2009-07-06 16:51 UTC] pietro dot baldassarri at unibo dot it
Sorry. I was too hasty. Bug seems apc related
 [2009-07-07 12:33 UTC] pietro dot baldassarri at unibo dot it
Bug is definitely an APC's issue. http://pecl.php.net/bugs/bug.php?id=16721
 [2009-07-07 17:26 UTC] jani@php.net
Thanks, then we can close this since it's not core issue.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Sep 20 00:01:28 2019 UTC