php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #4872 PHP doesn't work with oci8
Submitted: 2000-06-07 18:35 UTC Modified: 2006-07-17 09:03 UTC
From: bpinaud at ifrance dot com Assigned:
Status: Not a bug Package: OCI8 related
PHP Version: 4.0.0 Release OS: Mandrake linux 7.0
Private report: No CVE-ID: None
 [2000-06-07 18:35 UTC] bpinaud at ifrance dot com
I've got Orale 8.1.6 (Oracle 8i Rel2 for Linux) and if i compile php with oci8 support, apache doesn't want to start and there is nothing in the log of the system. without the oci8 support, php and apache works fine !
i use this for the configure scripts

configure --with-apxs --with-pgsql --with-oci8 --with-mm --enable-sigchild --enable-inline-optimizations

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-06-08 10:07 UTC] thies at cvs dot php dot net
    please relink your apache adding -lpthread to the LDFLAGS.

    the problem here is that a executable thats *not* linked
    agains -lpthread cannot load a shared library that is liked
    against -lpthread. (libphp4.so - linked against -lclntsh
    linked against -lpthread).

    this is a glibc-2.1 bug that supposed to be finxed in 2.2 (i
    heard)

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Jan 29 08:01:25 2020 UTC