php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48700 uninstall/install PHP problem?
Submitted: 2009-06-26 12:04 UTC Modified: 2009-08-14 12:25 UTC
From: yagogalego at hotmail dot com Assigned:
Status: Not a bug Package: Windows Installer
PHP Version: 5.3.0 OS: Windows XP Professional SP3
Private report: No CVE-ID: None
 [2009-06-26 12:04 UTC] yagogalego at hotmail dot com
Description:
------------
I am running PHP previous at 5.2.10 (exactly 5.2.9-2). 

I uninstall this previous PHP version (with uninstaller).

After, I install PHP 5.2.10 (exactly "php-5.2.10-win32-installer.msi") for upgrading my php system. 

Ok. No problem. 

Later, I look at windows environment variables and... the "path" variable have been replaced with only value "c:\programfiles\php"!, id est, the other values separated with ';' had been deleted. 

This similar issue I have it when I installed the previous php version (5.2.9-2). 

It is not problem for me because I have a updated backup of these environment variables but other people might have problems.

Thanks for listen. Greetings. 

 

-> Yago L.R.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-06-28 18:26 UTC] jmertic@php.net
Unable to reproduce this issue.
 [2009-08-14 12:25 UTC] yagogalego at hotmail dot com
----- QUOTE --------------------------------------------------
jmertic AT php DOT net => "Unable to reproduce this issue."
--------------------------------------------------------------

Hi jmertic! 

Unable to reproduce this issue? It is very easy. 

You need:

- Windows XP Professional Edition SP3
- "php-5.3.0-Win32-VC6-x86.msi" (PHP Win32 Installer VC6)
- "apache_2.2.11-win32-x86-openssl-0.9.8i.msi" (apache 2.x.x)

steps:

(1) execute and install "apache_2.2.11-win32-x86-openssl-0.9.8i.msi".
(2) go to "environment variables", find the "PATH" variable and backup it in a text file.

NOTE: "environment variables" are placed in Control Panel > System properties > advanced options > environment variables.

(3) execute and install "php-5.3.0-Win32-VC6-x86.msi".
(4) now, go to "environment variables" and view the result. 


What happens? 

The PHP WINDOWS INSTALLER overwrite the environment variable called 'PATH'. Id est, the PHP WINDOWS INSTALLER delete old before data that 'PATH' contained and put the new one. 

I write an example that you view how the PHP WINDOWS INSTALLER  modify 'path' variable. 

.................................................................
Example: 

- PATH environment variable content BEFORE install PHP 5.3.0

path = C:\programfiles\Java\sdk\;C:\programfiles\msgplus;C:\programfiles\webCamera\run;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem

- PATH environment variable content AFTER install PHP 5.3.0

PATH = C:\programfiles\mySoft\PHP\
.................................................................

NOTE: Not only overwrite the content, modify the original environment variable name 'path' (in lowercase) to 'PATH' (in uppercase) too. 

It is very easy. I don't know why is unable to reproduce this issue.

I think that this "php windows installer bug" is very important for windows users because applications (may) not run fine.  

Obviously, this bug is not fixed in PHP 5.3.0.

Greetings. Thanks for all.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Dec 03 08:03:33 2021 UTC