php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48650 pear broken in 5.2.10
Submitted: 2009-06-22 18:00 UTC Modified: 2009-07-10 22:00 UTC
Votes:24
Avg. Score:4.8 ± 0.6
Reproduced:23 of 23 (100.0%)
Same Version:23 (100.0%)
Same OS:4 (17.4%)
From: adam at oit dot gatech dot edu Assigned:
Status: Not a bug Package: PHAR related
PHP Version: 5.2.10 OS: Solaris 9
Private report: No CVE-ID:
 [2009-06-22 18:00 UTC] adam at oit dot gatech dot edu
Description:
------------
compiling php 5.2.10 with pear support leads to warnings on install and non-functional pear. Compilation of php 5.2.9 on same box with same config options gives working pear.

Reproduce code:
---------------
make install in source directory produces errors like:

   Warning: Cannot use a scalar value as an array in phar://install-pear-nozlib.phar/PEAR/ChannelFile.php on line 1391

running "pear install DB" produces the error:

   pear.php.net is using a unsupported protocal - This should never happen.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-06-22 18:03 UTC] adam at oit dot gatech dot edu
My compile options were:

CC=gcc \
export LD_LIBRARY_PATH=/usr/local/ssl/lib:/opt/services/amp/lib:/usr/local/lib
export PATH=/opt/SUNWspro/bin:/usr/ccs/bin:/usr/sbin:/usr/bin:/local/ssl/bin:/usr/xpg4/bin/:/services/mysql/bin:/opt/services/amp/bin:/usr/local/bin
export LDFLAGS="-R/opt/services/amp/lib -L/opt/services/amp/lib -R/usr/local/ssl/lib -L/usr/local/ssl/lib -R/usr/local/lib -L/usr/local/lib"
export CFLAGS="-R/opt/services/amp/lib -L/opt/services/amp/lib -R/usr/local/ssl/lib -L/usr/local/ssl/lib -R/usr/local/lib -L/usr/local/lib"
SSL_BASE=/opt/local/ssl \
./configure \
--with-apxs2=/opt/services/amp/apache2/bin/apxs \
--prefix=/opt/services/amp/apache2/php \
--with-config-file-path=/opt/services/amp/apache2/php/lib \
--with-mysql=/services/mysql \
--with-mysqli=/services/mysql/bin/mysql_config  \
--with-ldap=/usr/local/ldap \
--with-mcrypt \
--with-curl=/opt/services/amp \
--with-openssl \
--with-gd \
--with-zlib=/usr/local \
--enable-mbstring \
--with-xsl=/opt/services/amp \
--with-libxml-dir=/opt/services/amp \
--with-jpeg-dir=/usr/local \
--with-png-dir=/usr/local \
--with-freetype-dir=/usr/local \
--enable-libgcc
 [2009-06-22 23:55 UTC] mlavi at sgi dot com
Appears to be a duplicate of bugs: 48603 and 48625.
http://bugs.php.net/bug.php?id=48603
http://bugs.php.net/bug.php?id=48625
 [2009-06-25 10:00 UTC] php-user at voos dot de
Confirmed for

Debian 4
Debian 5
 [2009-06-25 10:12 UTC] thomas dot parrott at jellyfish dot co dot uk
Confirmed, during RPM build on CentOS 5.3 that works for 5.2.9, I get those same errors.

PEAR is then broken on install.
 [2009-06-25 18:36 UTC] bah at thisisnotmyrealmail dot com
Same on fedora core 3 x86_64.
 [2009-06-26 16:31 UTC] alexc223 at googlemail dot com
Same here when compiling 5.2.10 on Debian Lenny. It all configures and compiles fine, though the PHP warnings appear and get the same unsupported protocal (should be protocol btw ;)). PHP 5.2.9 and previous work just fine.
 [2009-07-07 13:41 UTC] tremclem at yahoo dot com
Pear is missing and my install on Solaris 10 breaks at make install.  Someone please fix and release 5.2.11 pronto. Trem
 [2009-07-10 22:00 UTC] jani@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 23 14:02:33 2014 UTC