php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48624 .user.ini never gets parsed
Submitted: 2009-06-21 01:41 UTC Modified: 2009-06-22 21:44 UTC
From: ct at swin dot edu dot au Assigned: pajoye
Status: Closed Package: CGI/CLI related
PHP Version: 5.3.0RC4 OS: Red Hat Enterprise Linux 5.3
Private report: No CVE-ID:
 [2009-06-21 01:41 UTC] ct at swin dot edu dot au
Description:
------------
sapi/cgi/cgi_main.c:

In the function php_cgi_ini_activate_user_config(), php_parse_user_ini_file() is never reached when path_len > doc_root_len


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-06-21 08:59 UTC] pajoye@php.net
My tests pass, maybe I oversaw something. Have to check again before final.
 [2009-06-22 01:20 UTC] pajoye@php.net
Can you test this patch http://pastebin.com/m183ef6ef? I did not test it yet but it looks like it could be the cause of this bug.

In any case I will test it and commit (or really fix it if this patch is not enough) later today.


 [2009-06-22 01:34 UTC] ct at swin dot edu dot au
Yes, that patch is effectively what I'm running at the moment and it works.
 [2009-06-22 21:44 UTC] pajoye@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 03:02:48 2014 UTC