php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48534 Infinite loop with: log_errors+display_startup_errors+no timezone
Submitted: 2009-06-11 22:24 UTC Modified: 2009-07-07 15:40 UTC
Votes:4
Avg. Score:3.5 ± 1.7
Reproduced:3 of 4 (75.0%)
Same Version:1 (33.3%)
Same OS:3 (100.0%)
From: paul at mantisforge dot org Assigned: derick
Status: Not a bug Package: PHP options/info functions
PHP Version: 5.3.0RC3 OS: Windows 32bit
Private report: No CVE-ID:
 [2009-06-11 22:24 UTC] paul at mantisforge dot org
Description:
------------
Calling php from command line with (for example):

c:\php\php -c "c:\php\foo.ini" -i

Results in an infinite logging loop if 
a) display_startup_errors is on
b) no timezone has been set in php.ini
c) error logging to file is on

Reproduce code:
---------------
PHP.ini:

log_errors = On
error_log = "c:\temp\php.log"
display_startup_errors = On

Expected result:
----------------
phpinfo(); is displayed

Actual result:
--------------
*snip*
ctype

ctype functions => enabled

date

date/time support => enabled
"Olson" Timezone Database Version => 2009.9
Timezone Database => internal

Warning: Unknown: It is not safe to rely on the system's timezone 
settings. You
are *required* to use the date.timezone setting or the 
date_default_timezone_set
() function. In case you used any of those methods and you are still 
getting thi
s warning, you most likely misspelled the timezone identifier. We 
selected 'Euro
pe/London' for '1.0/DST' instead in Unknown on line 0

Warning: Unknown: It is not safe to rely on the system's timezone 
settings. You
are *required* to use the date.timezone setting or the 
date_default_timezone_set
() function. In case you used any of those methods and you are still 
getting thi
s warning, you most likely misspelled the timezone identifier. We 
selected 'Euro
pe/London' for '1.0/DST' instead in Unknown on line 0

Warning: Unknown: It is not safe to rely on the system's timezone 
settings. You
are *required* to use the date.timezone setting or the 
date_default_timezone_set
() function. In case you used any of those methods and you are still 
getting thi
s warning, you most likely misspelled the timezone identifier. We 
selected 'Euro
pe/London' for '1.0/DST' instead in Unknown on line 0
....
...
..
.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-06-12 17:26 UTC] stas@php.net
This is a consequence of not-complete fix for bug #48247. I have a proposed fix, Derick needs to look at it.
 [2009-06-18 15:21 UTC] pajoye@php.net
Will be fixed after 5.3.0
 [2009-07-03 22:14 UTC] info at kanenas dot net
Although date.timezone = "Europe/Athens" (or date.timezone = 'Europe/Athens' or date.timezone = Europe/Athens) is set in php.ini problem still persists in 5.3.0 VC9 x86 Non Thread Safe (2009-Jun-30 08:52:54).
Windows Vista Home Premium, IIS 7.0 FastCgi. This is what you get...

PHP Warning:  PHP Startup: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Helsinki' for '3.0/DST' instead in Unknown on line 0
 [2009-07-05 12:47 UTC] jom at grosjo dot net
This bug STILL EXISTS IN THE RELEASED VERSION (5.3.0)
 [2009-07-05 12:51 UTC] pajoye@php.net
Instead of being loud or use a keyboard with a broken caps lock, can you please read carefully what I wrote earlier last month?

"Will be fixed after 5.3.0"

I think it is clear.
 [2009-07-05 14:26 UTC] jom at grosjo dot net
So there are no reason to *release" 5.3 when it is so full of bugs !!!!
 [2009-07-05 18:36 UTC] pajoye@php.net
This issue was not critical enough to be a stopping point. It is easily fixable by actually doing the right thing:

Set a correct timezone in your php.ini.
 [2009-07-05 19:01 UTC] jom at grosjo dot net
No, this is the ACTUAL bug: *Whatever* timezone you define or not in php.ini, php launch the loop above. 

Php 5,30 is just unusable in the current status. Maybe you consider this not critical, but it makes the complete work on 5.3 useless, because we can not use it !
 [2009-07-05 20:25 UTC] paul at mantisforge dot org
Jom, 

You should only get this behaviour if you do not specifiy a timezone in php.ini.

In addition, display_startup_errors should normally be OFF for a production site, which seemed to be one of the requirements to actually hit this issue.

NOTE: if your running fastcgi and edit the relevant php.ini, you may need to restart the application pool for the change to take effect.

Paul
 [2009-07-07 15:40 UTC] jani@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

See bug #48247
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 16 04:02:11 2014 UTC