php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48425 Can not call static methods from .net DLL
Submitted: 2009-05-29 04:57 UTC Modified: 2020-02-08 11:22 UTC
Votes:6
Avg. Score:4.2 ± 0.9
Reproduced:6 of 6 (100.0%)
Same Version:1 (16.7%)
Same OS:3 (50.0%)
From: halflife at cableone dot net Assigned: cmb (profile)
Status: Duplicate Package: COM related
PHP Version: 5.2.9 OS: Windows Server 2003
Private report: No CVE-ID: None
 [2009-05-29 04:57 UTC] halflife at cableone dot net
Description:
------------
I can call any public methods in a public class from my dll no 
problem, but calling any methods that are set as static, results in 
the error

Fatal error: Call to undefined method com::DoMD5() in 
C:\wamp\www\xxx\netphp.php on line 5





Reproduce code:
---------------
Source to dll class <a href=http://www.dlgnetworks.com/HashPotato.cs

PHP Code calling it

$DLGtb = new COM("DLG.Crypto.HashPotato");
echo $DLGtb->DoMD5("test");


Expected result:
----------------
Should return the MD5 of the string

Actual result:
--------------
Fatal error: Call to undefined method com::DoMD5()

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-02-08 11:22 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2020-02-08 11:22 UTC] cmb@php.net
Duplicate of bug #50473.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat May 30 00:01:25 2020 UTC