php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #4834 configure and running problem with RH6.2?
Submitted: 2000-06-06 05:19 UTC Modified: 2000-08-01 01:42 UTC
From: andras at izone dot hu Assigned:
Status: Closed Package: IMAP related
PHP Version: 4.0 Release Candidate 2 OS: Linux 2.2.14 (RedHat 6.2)
Private report: No CVE-ID: None
 [2000-06-06 05:19 UTC] andras at izone dot hu
problem #1

when ./configure-ing with --with-imap, it claims it cannot
find the IMAP library:
checking for IMAP support... configure: error: Cannot find imap library. Please check your IMAP installation

...but indeed there it is (standard RH 6.2 install WITH imap-devel installed, too.)

PHP3 ./configure --with-imap runs OK.

problem might be in the configure script itself:
(~line 14950)
if test -r "$IMAP_DIR/c-client/c-client.a"; then

this implies that if the imap includes (rfc822.h etc) are in, say, /usr/include/imap (as they are in RH6.2), then the lib must be in /usr/include/imap/c-client/c-client.a . however, quite righteously, c-client.a is in /usr/lib! PHP3 has no problems with finding it.

problem #2
this is more cryptic, and happens in both 4.0 RC2 and PHP3.0.16. (yes, php4 is tested, too, i got around with a few tweaks and managed to get the ./configure script run just fine.) after make and make install, when i restart the web server with apachectl, i get the following message:

Cannot load /usr/local/apache/libexec/libphp3.so into server: /usr/local/apache/libexec/libphp3.so: undefined symbol: gss_mech_krb5

(same with libphp4.so.)

this RH6.2 install uses shadow passwords and MD5 passwords under PAM.

hyeeelp meee!

/etc/ld.so.conf:
---------------------
/usr/X11R6/lib
/usr/kerberos/lib
/usr/i486-linux-libc5/lib
/usr/lib
/usr/local/lib
---------------------

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-06-06 22:54 UTC] joey at cvs dot php dot net
If this is a 4.0 RC2 issue, why is it dying
when trying to load "libphp3.so"?	
 [2000-07-26 14:15 UTC] sniper@php.net
Problem #1:
-----------

Have you tried specifying the path for the --with-imap?

Like this:

./configure --with-imap=/usr

Problem #2:
-----------

See bug: #4424 for solution.

--Jani
 [2000-08-01 01:42 UTC] sniper@php.net
No user feedback. And this is not a bug. Misconfiguration.

--Jani
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Jan 28 00:03:34 2022 UTC