php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48239 Cannot Postgres loaded
Submitted: 2009-05-11 23:45 UTC Modified: 2009-05-12 02:58 UTC
From: aguiland06 at gmail dot com Assigned:
Status: Not a bug Package: PostgreSQL related
PHP Version: 5.2.9 OS: windows xp
Private report: No CVE-ID: None
 [2009-05-11 23:45 UTC] aguiland06 at gmail dot com
Description:
------------
Cannot  Postgres loaded, PHP.INI indicates that it s loaded ?
does not show up(loaded) in a  In  PHPINFO(). 

 


Reproduce code:
---------------
"Warning: pg_connect(): Unable to connect to PostgreSQL server

Running htpp://localhost/phppgamin:
Display Message:

"Your PHP installation does not support PostgreSQL. You need to recompile PHP using the --with-pgsql configure option."

text in  php.ini: 
;extension=php_ming.dll
extension=php_mssql.dll
;extension=php_msql.dll
extension=php_mysql.dll





Expected result:
----------------
 
I have never had this happen before ?



Actual result:
--------------
libpq.dll is in the path.

Note: Cannot  mssql load, does not show up(loaded) in a  In  PHPINFO(). 

Problem be repeat in php 6.0, postgres and mssql no loaded

 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-05-12 00:03 UTC] aguiland06 at gmail dot com
php.ini

extension=php_mssql.dll
extension=php_mysql.dll
extension=php_mysqli.dll
extension=php_pdo_pgsql.dll
extension=php_pdo_sqlite.dll
extension=php_pgsql.dll

no loaded postgres
 [2009-05-12 02:00 UTC] jani@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 [2009-05-12 02:54 UTC] aguiland06 at gmail dot com
Thanks.
 [2009-05-12 02:58 UTC] aguiland06 at gmail dot com
Thanks. but,  php 5.2.9 and 6.0, postgres and mssql no loaded, Problem be repeat in php 6.0, postgres and mssql no loaded. 
but I'll have a go if I can't solve it, I reverted to php 5.2.5 and it all worked again.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun May 19 15:01:31 2024 UTC