php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48220 idn_to_ascii: $errorcode is NULL
Submitted: 2009-05-10 12:08 UTC Modified: 2009-05-10 13:15 UTC
From: fh-phpbug at fholzhauer dot de Assigned:
Status: Not a bug Package: I18N and L10N related
PHP Version: 5.3.0RC2 OS: Ubuntu
Private report: No CVE-ID: None
 [2009-05-10 12:08 UTC] fh-phpbug at fholzhauer dot de
Description:
------------
The optional parameter $errorcode in idn_to_ascii() should return the IDNA error code, but is NULL after an error. 

See the example in the PHP documentation (http://de.php.net/manual/en/function.idn-to-ascii.php) for a description of the expected behaviour.

http://pastebin.com/m55d27e3c provides a PHPT testcase.

Reproduce code:
---------------
<?php
//http://de.php.net/manual/en/function.idn-to-ascii.php -> example
idn_to_ascii("xn--".chr(0xC3).chr(0xA4),$errorcode);
var_dump($errorcode);
?>



Expected result:
----------------
int(8)

Actual result:
--------------
NULL

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-05-10 13:15 UTC] bjori@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Unfortunately the docs are about the pecl/idn extension, not the PHP5.3 ext/intl extension (which includes that function).

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Aug 08 21:01:26 2020 UTC