php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48213 snmpapp.conf is broken and php cant load module
Submitted: 2009-05-09 20:25 UTC Modified: 2009-05-11 10:40 UTC
From: andywolk at gmail dot com Assigned:
Status: Not a bug Package: SNMP related
PHP Version: 5.2.9 OS: Windows 2003 Server
Private report: No CVE-ID: None
 [2009-05-09 20:25 UTC] andywolk at gmail dot com
Description:
------------
Normal file:
----cut here-----
#
# net-snmp (or ucd-snmp) persistent data file.
#
# DO NOT STORE CONFIGURATION ENTRIES HERE.
# Please save normal configuration tokens for snmpapp in SNMPCONFPATH/snmpapp.conf.
# Only "createUser" tokens should be placed here by snmpapp administrators.
#

engineBoots 28
oldEngineID 0x800007e580ec2c00002de4054a
----cut here-----
Bad file:
----cut here-----
#
# net-snmp (or ucd-snmp) persistent data file.
#
# DO NOT STORE CONFIGURATION ENTRIES HERE.
# Please save normal configuration tokens for snmpapp in SNMPCONFPATH/snmpapp.conf.
# Only "createUser" tokens should be placed here by snmpapp administrators.
#

#
# net-snmp (or ucd-snmp) persistent data file.
#
# DO NOT STORE CONFIGURATION ENTRIES HERE.
# Please save normal configuration tokens for snmpapp in SNMPCONFPATH/snmpapp.conf.
# Only "createUser" tokens should be placed here by snmpapp administrators.
#

engineBoots 18
engineBoots 18
engineBoots 18
00007e580ec2c00002de4054a
oldEngineID 0x800007e580ec2c00002de4054a
oldEngineID 0x800007e580ec2c00002de4054a
oldEngineID 0x800007e580ec2c00002de4054a
----cut here-----

Reproduce code:
---------------
File is broken when internet losts. I think it is dns+snmp problem.
Probably file is broken when no dns respond.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-05-09 20:38 UTC] jani@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 [2009-05-11 10:40 UTC] andywolk at gmail dot com
My PHP works under IIS as ISAPI extention.
A few scripts are run under php-cgi.exe
php_snmp.dll is set in php.ini

Sometimes, when a script calls snmp function, c:\usr\SNMP\PERSIST\snmpapp.conf breaks. After that IIS cannot run scripts. php-cgi.exe warn me simething like "cannot load module" and cannot run scripts too. All I can do is deleting snmpapp.conf. Next time PHP forks fine until new problem with this file.

Jani, are you sure about your first post?
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Mar 30 10:01:26 2020 UTC