php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48167 undefined function checkdnsrr()
Submitted: 2009-05-06 16:32 UTC Modified: 2009-11-25 10:37 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: frew dot robert at gmail dot com Assigned: fa (profile)
Status: Closed Package: *Network Functions
PHP Version: 5.3.0RC1 OS: Linux
Private report: No CVE-ID: None
 [2009-05-06 16:32 UTC] frew dot robert at gmail dot com
Description:
------------
When using function checkdnsrr(), I get a Fatal error: Call to undefined function checkdnsrr() in test.php.

You can view this error live at http://www.mxxm.com/test.php.



Reproduce code:
---------------
<?
$ip = $_SERVER['REMOTE_ADDR'];
if (checkdnsrr($ip, "MX")) {
	echo 'Yes';
} else {
	echo 'No';
}
?>

Expected result:
----------------
True or false.

Actual result:
--------------
Fatal error: Call to undefined function checkdnsrr()

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-05-06 16:41 UTC] scottmac@php.net
This function is only available if the configure script can find bind on your system.

If you look at your config.log you'll probably find that its missing.
 [2009-05-06 19:30 UTC] fa@php.net
That's not mentioned in the documentation, shouldn't this be converted to a documentation bug then?
 [2009-05-06 19:34 UTC] pajoye@php.net
Yes, set it as to be documented.

Please not that as in 5.3, it is always available on windows.
 [2009-05-06 21:19 UTC] frew dot robert at gmail dot com
Recompiled PHP and the problem went away.
 [2009-05-11 09:38 UTC] kalle@php.net
Alot of functions may not be available if the configure script does not find them on Unix, wheres on Windows they are either available or not, not *maybe*. We really need to list these in the manual
 [2009-11-25 10:37 UTC] svn@php.net
Automatic comment from SVN on behalf of vrana
Revision: http://svn.php.net/viewvc/?view=revision&revision=291298
Log: Requires Bind (bug #48167)
 [2009-11-25 10:37 UTC] vrana@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed May 22 23:01:33 2019 UTC