|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48156 Allow LTP 1.7 when compiling with --enable-gcov
Submitted: 2009-05-05 20:28 UTC Modified: 2009-05-06 14:06 UTC
From: shahar dot e at zend dot com Assigned:
Status: Closed Package: Compile Failure
PHP Version: 5.3.0RC1 OS: Mac OS X 10.5
Private report: No CVE-ID:
 [2009-05-05 20:28 UTC] shahar dot e at zend dot com
When compiling with --enable-gcov the configure script is looking for LTP but only LTP 1.5 or 1.6 are accepted. 

I have manually modified to allow my currently installed LTP 1.7 and it worked flawlessly - I think 1.7 should be allowed as well. 

I modified ltp_version_list in line 731 to include 1.7 as well (I would supply a patch but is a one line change, 4 byte addition).


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2009-05-06 14:06 UTC]
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
Thank you for the report, and for helping us make PHP better.

PHP Copyright © 2001-2015 The PHP Group
All rights reserved.
Last updated: Wed Dec 02 03:01:32 2015 UTC