php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48146 A false Japanese explanation on the for statement
Submitted: 2009-05-04 14:20 UTC Modified: 2009-05-04 14:36 UTC
From: sekiguchi328 at yahoo dot co dot jp Assigned:
Status: Closed Package: Translation problem
PHP Version: Irrelevant OS: N/A
Private report: No CVE-ID: None
 [2009-05-04 14:20 UTC] sekiguchi328 at yahoo dot co dot jp
Description:
------------
Explanation of the for statement in PHP reference manual includes a comentary notes on the special case that the second expression of the for statement was empty.  (e.g., "for(;;)".)  The last English sentense of the fourth paragraph reads: "This may not be as useless as you might think, since often you'd want to end the loop using a conditional break  statement instead of using the for truth expression." ?@This is somewhat tortuous sentense, but it says, in short, "This is useful."  In Japanese translation, however, the corresponding text says "This is less convenient than you think", making totally opposite and false statement.  The problematic part of the Japanese text that leads to the opposit meaning is "?v?????قǕ֗??ł͂Ȃ??????????܂???".

Reproduce code:
---------------
Access to http://jp.php.net/manual/ja/control-structures.for.php

Expected result:
----------------
Replace the problematic part "?v?????قǕ֗??ł͂Ȃ??????????܂???" with "???S?҂??z?????????肸???ƕ֗??ł?".  (This rewriting used a word "???S??" (a novice) in place of "you" in "you might think", because it is better to avoid second person pronouns in Japanese sentense, and it makes sure that "you" in this context is assumed to be a no experienced programmer.)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-05-04 14:36 UTC] takagi@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.

http://news.php.net/php.doc.ja/2466
# I changed your suggestion a little bit.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Dec 04 02:03:36 2021 UTC