php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48144 A wrong Japanese translation regarding "static" keyword
Submitted: 2009-05-04 10:58 UTC Modified: 2009-05-04 11:13 UTC
From: sekiguchi328 at yahoo dot co dot jp Assigned:
Status: Closed Package: Translation problem
PHP Version: Irrelevant OS: N/A
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sekiguchi328 at yahoo dot co dot jp
New email:
PHP Version: OS:

 

 [2009-05-04 10:58 UTC] sekiguchi328 at yahoo dot co dot jp
Description:
------------
The page for the "static keyword" in the Japanese translation of the PHP reference manual, available on http://jp.php.net/manual/ja/language.oop5.static.php contains a wrong text.  The English text "A member declared as static can not be accessed with an instantiated class object (though a static method can)." is currently translated as "static ?ȃ????o?́A?C???X?^???X?????ꂽ?N???X?I?u?W?F?N?g?????A?N?Z?X???邱?Ƃ͂ł??܂??? (static ?ȃ??\?b?h?????͉”\?ł?) ?B", and is false.  (The current Japanese text reads something like: An instantiated class object can't access to a member declared as static.  (Though static methods can access [to the member declared as static].)) 

Reproduce code:
---------------
Access to http://jp.php.net/manual/ja/language.oop5.static.php and read the first paragraph.

Expected result:
----------------
A suggested Japanese text is: "static ?Ƃ??Đ錾???ꂽ?????o?ɁA?C???X?^???X?????ꂽ?N???X?I?u?W?F?N?g????ăA?N?Z?X???邱?Ƃ͂ł??܂??? (static ?ȃ??\?b?h?ɂ̓A?N?Z?X?ł??܂?)?B


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-05-04 11:13 UTC] takagi@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.

http://news.php.net/php.doc.ja/2464
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Nov 29 10:03:14 2021 UTC