php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48086 PDO-OCI fails to configure due to lib suffix assumptions
Submitted: 2009-04-27 10:15 UTC Modified: 2016-03-08 01:29 UTC
From: petri dot mahanen at brainalliance dot com Assigned:
Status: Not a bug Package: PDO OCI
PHP Version: 5.2.9 OS: Mac OS X 10.5.6
Private report: No CVE-ID: None
 [2009-04-27 10:15 UTC] petri dot mahanen at brainalliance dot com
Description:
------------
PDO OCI fails to configure on OS X, as the library suffix is assumed to be '.so', while it is '.dylib'. $SHLIB_SUFFIX_NAME is correctly set in configure, but not used in this case.

The issue also seems to be reported in a comment to unrelated bug 39312, with a patch.

Reproduce code:
---------------
./configure [...] --enable-pdo --with-pdo-oci=instantclient,/opt/instantclient_10_2,10.2.0.4


Expected result:
----------------
successful configure


Actual result:
--------------
checking Oracle OCI support for PDO... yes
checking Oracle Install-Dir... instantclient,/opt/instantclient_10_2,10.2.0.4
checking if that is sane... yes
checking for oci.h... /opt/instantclient_10_2/sdk/include
configure: error: I'm too dumb to figure out where the libraries are in your Instant Client install


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-04-27 15:11 UTC] jani@php.net
Same as bug #39312
 [2009-04-28 12:09 UTC] petri dot mahanen at brainalliance dot com
Same as comment [29 Jan 11:37am UTC] michael-ring at t-online dot de in bug #39312.
 [2016-03-08 01:29 UTC] sixd@php.net
-Package: PDO related +Package: PDO OCI
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Nov 17 18:01:33 2019 UTC