php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48043 8192 bytes files crash
Submitted: 2009-04-22 10:32 UTC Modified: 2009-04-22 10:59 UTC
From: hannes dot magnusson at gmail dot com Assigned:
Status: Not a bug Package: Reproducible crash
PHP Version: 5.3CVS-2009-04-22 (CVS) OS: Linux
Private report: No CVE-ID: None
 [2009-04-22 10:32 UTC] hannes dot magnusson at gmail dot com
Description:
------------
Any 8192 byte file crashes under apach2.
Doesn't even have to have <?php tags, just as long as the file is 8192bytes.

For some reason I cannot reproduce this under CLI

Reproduce code:
---------------
- Create a file with the size of 8192
- Compile PHP as apache2 module
- Hit the file

Actual result:
--------------
#0  0xb7e69211 in memchr () from /lib/tls/i686/cmov/libc.so.6
#1  0xb733c98a in lex_scan (zendlval=0xbfb628ac) at Zend/zend_language_scanner.l:1608
#2  0xb73635d9 in zendlex (zendlval=0xbfb628a8) at /usr/src/php/5.3/Zend/zend_compile.c:4880
#3  0xb7335a60 in zendparse () at /usr/src/php/5.3/Zend/zend_language_parser.c:3280
#4  0xb733bc59 in compile_file (file_handle=0xbfb62a8c, type=2) at Zend/zend_language_scanner.l:337
#5  0xb73b05bf in ZEND_INCLUDE_OR_EVAL_SPEC_TMP_HANDLER (execute_data=0xb86123d0) at /usr/src/php/5.3/Zend/zend_vm_execute.h:5166
#6  0xb73a0fdd in execute (op_array=0xb8719ba0) at /usr/src/php/5.3/Zend/zend_vm_execute.h:104
#7  0xb7376a9c in zend_execute_scripts (type=8, retval=0x0, file_count=3) at /usr/src/php/5.3/Zend/zend.c:1188
#8  0xb730ad4e in php_execute_script (primary_file=0xbfb64e44) at /usr/src/php/5.3/main/main.c:2157
#9  0xb743596c in php_handler (r=0xb860de78) at /usr/src/php/5.3/sapi/apache2handler/sapi_apache2.c:648
#10 0xb804330d in ap_run_handler () from /usr/sbin/apache2
#11 0xb8046f2f in ap_invoke_handler () from /usr/sbin/apache2
#12 0xb8056190 in ap_internal_redirect () from /usr/sbin/apache2
#13 0xb805620c in ap_process_request () from /usr/sbin/apache2
#14 0xb8052f78 in ?? () from /usr/sbin/apache2
#15 0xb804b6fd in ap_run_process_connection () from /usr/sbin/apache2
#16 0xb805b781 in ?? () from /usr/sbin/apache2
#17 0xb805bad9 in ?? () from /usr/sbin/apache2
#18 0xb805c830 in ap_mpm_run () from /usr/sbin/apache2
#19 0xb802e0e9 in main () from /usr/sbin/apache2


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-04-22 10:59 UTC] scottmac@php.net
Duplicate of #48034
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jul 06 21:01:04 2020 UTC