php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47942 dynamic library suhosin.so could not be loaded
Submitted: 2009-04-10 03:48 UTC Modified: 2009-04-10 07:59 UTC
From: rajesh dot mohan at asia dot bnpparibas dot com Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 5.2CVS-2009-04-10 (snap) OS: AIX 5.3
Private report: No CVE-ID: None
 [2009-04-10 03:48 UTC] rajesh dot mohan at asia dot bnpparibas dot com
Description:
------------
After installation of PHP 5.2.6 on AIX 5.3, i tried to test it in the command line through php -v and php -r "phpinfo()" and both fails with the reason suhosin.so could not be loaded as below:

$UAT>/opt/pware/bin>php -r "phpinfo()"
PHP Warning:  PHP Startup: Unable to load dynamic library './suhosin.so' - Could not load module ..
System error: No such file or directory in Unknown on line 0
PHP Parse error:  syntax error, unexpected $end in Command line code on line 1

$UAT>/opt/pware/bin>php -v
PHP Warning:  PHP Startup: Unable to load dynamic library './suhosin.so' - Could not load module ..
System error: No such file or directory in Unknown on line 0
PHP 5.2.6 with Suhosin-Patch 0.9.6.2 (cli) (built: Dec 26 2008 09:14:36)
Copyright (c) 1997-2008 The PHP Group



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-04-10 07:59 UTC] kalle@php.net
Your php.ini tries to load an extension that does not exist on your system, check that you have set the extension_dir & extension directives correctly.

For more help on that paticular extension, contact the extension authors of suhosin.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Mar 03 02:01:30 2024 UTC