php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47864 faulting module aspell-15.dll
Submitted: 2009-04-01 15:12 UTC Modified: 2009-04-01 18:36 UTC
From: todd at magnifisites dot com Assigned:
Status: Not a bug Package: Pspell related
PHP Version: 5.2.9 OS: Windows
Private report: No CVE-ID: None
 [2009-04-01 15:12 UTC] todd at magnifisites dot com
Description:
------------
The latest version of the bundled aspell-15.dll in the PHP Windows distribution (versions > 5.2.6, including latest 5.2.9.9) fails with an Application error code "faulting module aspell-15.dll" when attempting to use pspell functions.

Reproduce code:
---------------
<?php
$pspell_link = pspell_new("en");
if (pspell_check($pspell_link, "testt")) {
    echo "This is a valid spelling";
} else {
    echo "Sorry, wrong spelling";
}
?>

Expected result:
----------------
On PHP 5.2.6 and earlier installations the result is:

    Sorry, wrong spelling

The same output is expected.

Actual result:
--------------
The latest version of the bundled aspell-15.dll in the PHP Windows distribution (versions > 5.2.6, including latest 5.2.9.9) fails with the following Application error code when executing a script via the Apache http server (here we are using Apache 2.2.8.0, but can be reproduced on later versions of Apache as well, see notes below):

Faulting application httpd.exe, version 2.2.8.0, faulting module aspell-15.dll, version 0.0.0.0, fault address 0x0008cef6.

I tested this on Apache 2.2.10.0 and PHP 5.2.8 for Windows with the same results.

Running a script from the command line:
        php -f pspell.php
returns a similar error:

Faulting application php.exe, version 5.2.9.9, faulting module
aspell-15.dll, version 0.0.0.0, fault address 0x0008cef2.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-04-01 16:01 UTC] pajoye@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

Bug in pspell library, we won't be able to fix.
 [2009-04-01 18:07 UTC] todd at magnifisites dot com
Thanks, but I did indeed search first and found but 5 bugs regarding the PHP > 5.2.6 issue on the Windows platform.  However, they do not state the cause and have been marked as no longer open but either bogus or no feedback.  I found the cause and better yet, I actually think I found the solution.

I mentioned in the initial bug submission that I traced the issue back to a specific dll, aspell-15.dll, which I noticed the PHP 5.2.6 distribution does *not* contain.  I removed the dll from the php installation root, C:\php in my case, and restarted the Apache server.

pspell functions are now working again as expected.  I tested this on both the 5.2.8 and 5.2.9.9 distributions successfully.

Suggested Recovery:
-------------------
Remove the aspell-15.dll from the Windows distribution.
 [2009-04-01 18:16 UTC] pajoye@php.net
it is removed, in 5.3+
 [2009-04-01 18:36 UTC] todd at magnifisites dot com
Thank you :)
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Nov 13 22:01:29 2019 UTC