php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47729 Hardly usable hr.php.net
Submitted: 2009-03-20 10:32 UTC Modified: 2009-05-08 16:02 UTC
Votes:5
Avg. Score:4.0 ± 1.3
Reproduced:4 of 5 (80.0%)
Same Version:3 (75.0%)
Same OS:3 (75.0%)
From: senker at gmail dot com Assigned: danbrown (profile)
Status: Wont fix Package: Website problem
PHP Version: Irrelevant OS: WIn/Lin
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2009-03-20 10:32 UTC] senker at gmail dot com
Description:
------------
Being from Croatia, I always get forwarded to hr.php.net which is either on a really bad hardware, bad network or it's admin should be reminded to actually do something about it, as it is horribly slow, sometimes even hanging, and this is going on for quite a long time.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-03-20 10:37 UTC] bjori@php.net
It is blazing fast for me (from Norway).

Maybe some routing issues from you to the server?
 [2009-03-20 14:28 UTC] danbrown@php.net
It may be routing, or it may be an intermittent problem.  I 
frequently - like this morning - have issues in reaching it.  In 
fact, right now, it's completely unreachable from the US 
(Pennsylvania).
 [2009-03-21 08:56 UTC] senker at gmail dot com
Hi,

no routing issues, tested on two locations.

It's a bit better today, but tends to get slow lately.

Tracing route to ftp.linux.hr [193.198.184.20]
over a maximum of 30 hops:

  1     1 ms    <1 ms    <1 ms  192.168.1.2
  2    61 ms    41 ms     *     172.29.252.58
  3    12 ms     7 ms    32 ms  172.29.1.49
  4    32 ms    35 ms    13 ms  win-b2-link.telia.net [213.248.84.189]
  5    68 ms    69 ms    65 ms  hbg-bb2-link.telia.net [80.91.252.82]
  6    91 ms    85 ms   138 ms  bpt-b2-link.telia.net [80.91.250.133]
  7   116 ms    81 ms   115 ms  dante-ic-125711-bpt-b2.c.telia.net [80.239.134.2]
  8    92 ms   102 ms   123 ms  so-6-1-0.rt1.vie.at.geant2.net [62.40.112.13]
  9    52 ms    51 ms    74 ms  carnet-gw.rt1.vie.at.geant2.net [62.40.124.10]
 10    56 ms    65 ms    59 ms  CN-Srce-01-ES.zg.core.CARNet.hr [193.198.228.126]
 11    98 ms   135 ms   112 ms  CN-Nsk-01-ES.zg.core.CARNet.hr [193.198.229.14]
 12    67 ms    52 ms    52 ms  ftp.linux.hr [193.198.184.20]

Linux.hr takes quite a lot of time to open on occassions, so does hr.php.net.

php.net opens flawlessly.
 [2009-03-21 14:07 UTC] danbrown@php.net
Senker,

That doesn't discount the possibility of routing issues.  From some 
points in the world, including my home office in Pennsylvania, the 
mirror does not respond.  From other points, it responds, but very 
slow.  And from still other points, it responds just fine, as bjori 
mentioned.  All tests were performed multiple times in the same few-
minute span of time.

I will contact the maintainer of the hr.php.net mirror to see if 
there are any problems that they notice, and if their response turns 
up nothing of interest, this ticket will be closed.

In either case, a note of this will be added to the mirror's file in 
our system, and I will let you know if and when I've heard back from 
the maintainer.

 [2009-05-07 01:22 UTC] ivoras at gmail dot com
I have reported this issue previously in October 2008 on the mirrors@php.net mailing list, and the mirror was apparently temporarily taken down from php.net redirection services but it was later put up again, with the same problems.

Please note that the *users* of the mirror have nothing to do with the *administrators* of the mirror - if the admins cannot maintain the service, the users should not have trouble because of it. Take it down.
 [2009-05-07 01:33 UTC] danbrown@php.net
We will not be taking the mirror down.  Once again, testing from 
various points in the world, the mirror responds just fine for me.  In 
fact, I believe you are still the only one who has reported such 
problems.  And while I trust what you are saying is true, there should 
be no changes expected at this time.

However, this doesn't mean that you need to put up with slow speeds by 
any means.

Go to http://php.net/my and, at the bottom of the page, you can 
disable the automatic geoIP detection and redirection, and choose a 
mirror to use as your regular mirror.

Aside from that, while I'm sorry that it's not responding well for 
you, it's the extent of the troubleshooting advice we're able to offer 
you at this time.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Jul 03 16:03:37 2022 UTC