php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47420 PEAR chunked html theme and navigation table
Submitted: 2009-02-17 11:16 UTC Modified: 2009-02-17 19:13 UTC
From: pear at laurent-laville dot org Assigned: cweiske (profile)
Status: Closed Package: Doc Build problem
PHP Version: Irrelevant OS: Windows XP
Private report: No CVE-ID: None
 [2009-02-17 11:16 UTC] pear at laurent-laville dot org
Description:
------------
On my first try to build my CHM theme for a partial render of PEAR Manual, I thought that there is an error in header navigation table.

With current CHM theme, the title of page is not centered as expected but left aligned.

This is why I thought there is a problem with prev link (but it's not).

Error came from PEAR chunked html theme 
File: http://cvs.php.net/viewvc.cgi/phd/themes/pear/pearchunkedhtml.php?annotate=1.5.2.2.2.2 
Line: 103

<tr><th colspan="3" align="center">{$title}</th></tr>

The inline (expected behavior) is not provided by align="center" because the global style sheet "reset-fonts.css" is applied with 
selector 

caption th {text-align: left;}


So to fix it I suggest to replace in pearchunkedhtml.php v 1.5.2.2.2
line 103 by this one

<tr><th colspan="3" style="text-align: center">{$title}</th></tr>

And XHTML will be followed




Expected result:
----------------
Title Centered

Actual result:
--------------
Title is left aligned

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-02-17 19:13 UTC] cweiske@php.net
This bug has been fixed in CVS. Since the websites are not directly
updated from the CVS server, the fix might need some time to spread
across the globe to all mirror sites, including PHP.net itself.

Thank you for the report, and for helping us make PHP.net better.

Will be in 0.4.5
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Jul 03 17:05:45 2022 UTC