php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47419 Add support for external theme
Submitted: 2009-02-17 10:36 UTC Modified: 2009-09-04 15:42 UTC
From: pear at laurent-laville dot org Assigned:
Status: Closed Package: Doc Build problem
PHP Version: Irrelevant OS: Windows XP
Private report: No CVE-ID: None
 [2009-02-17 10:36 UTC] pear at laurent-laville dot org
Description:
------------
Because I wanted to build my own CHM version of a partial PEAR Manual rendering, my first try was to run PhD with only the switch 

-t mypearchm

To realize just after that, even if class is available in phd/themes/pear directory

File  mypearchm.php
Class mypearchm extends pearchunkedhtml

It won't run because themes list are hard-coded into phpd/config.php



Reproduce code:
---------------
phd -f xhtml -t mypearchm -o build/tmp -d .manual.xml



Actual result:
--------------
[11:23:40 - E_USER_ERROR] C:\wamp\bin\php\php5.2.8\PEAR\phd\config.php:478
        Unknown theme 'mypearchm'

Patches

Add a Patch

Pull Requests

Add a Pull Request

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Oct 04 10:05:51 2022 UTC