php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47404 mysql_fetch_array
Submitted: 2009-02-16 11:49 UTC Modified: 2009-02-16 11:53 UTC
From: jignasha_86 at yahoo dot co dot in Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 5.2.9RC2 OS: All
Private report: No CVE-ID: None
 [2009-02-16 11:49 UTC] jignasha_86 at yahoo dot co dot in
Description:
------------
When we allow < > in data from user, that will inserted correctly
in database,Even running query manually will give correct results
and fetching data, but when we do it with mysql_fetch_array
function, It will give blank data in between < > brackets

Reproduce code:
---------------
If $data = "This is < testing > data";
Insert this string as one field of database 
It will get inserted correctly,when we fetch
using any MySQL feching function like mysql_fetch_array or
mysql_fetch_row, it will be like
"This is data";
Eliminating < > and data in between that brackets


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-02-16 11:53 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Tip: Do a \"view source\" in your browser.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Tue Jan 31 21:05:54 2023 UTC