php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47360 Compilation of PHP extension example failed with PHP 5.2.8-r2
Submitted: 2009-02-11 14:33 UTC Modified: 2009-02-11 20:23 UTC
From: rudolf dot schonecker at seznam dot cz Assigned:
Status: Not a bug Package: *Extensibility Functions
PHP Version: 5.2CVS-2009-02-11 (snap) OS: Linux 2.6.27-gentoo-r8 i686
Private report: No CVE-ID: None
 [2009-02-11 14:33 UTC] rudolf dot schonecker at seznam dot cz
Description:
------------
I have try to build a PHP extension Hello world available at the page http://devzone.zend.com/node/view/id/1021#Heading6. Under PHP 5.2.6-r7 everything works well, but after upgrading PHP package to 5.2.8-r2 (the latest available in portage) I'am not able to compile this example.

Compiler:
 [3] i686-pc-linux-gnu-4.3.3 *

Important packages:
 sys-devel/autoconf-2.63
 sys-devel/libtool-1.5.26 or 2.2.6a


Reproduce code:
---------------
Use the first example from given page, create three given files (config.m4, php_hello.h, hello.c) and run

$ phpize
$ ./configure --enable-hello
$ make



Expected result:
----------------
Sucessfull compilation and existing hello.so.

Actual result:
--------------
$ make
/bin/sh /home/lubos/tmp/php/libtool --mode=compile gcc  -I. -I/home/lubos/tmp/php -DPHP_ATOM_INC -I/home/lubos/tmp/php/include -I/home/lubos/tmp/php/main -I/home/lubos/tmp/php -I/usr/lib/php5/include/php -I/usr/lib/php5/include/php/main -I/usr/lib/php5/include/php/TSRM -I/usr/lib/php5/include/php/Zend -I/usr/lib/php5/include/php/ext -I/usr/lib/php5/include/php/ext/date/lib  -I/usr/lib/php5/include/php -DHAVE_CONFIG_H  -g -O2   -c /home/lubos/tmp/php/hello.c -o hello.lo
/home/lubos/tmp/php/libtool: line 460: CDPATH: command not found
/home/lubos/tmp/php/libtool: line 1152: func_opt_split: command not found
libtool: Version mismatch error.  This is libtool 2.2.6, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.2.6
libtool: and run autoconf again.
make: *** [hello.lo] Error 63

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-02-11 20:23 UTC] jani@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Jan 21 02:01:23 2020 UTC